View Full Version : Question

03-13-2008, 11:17 PM
Ok so i dont know how long it has been doing this because i normally listen to music all the time when i drive but i was driving today with no music on and noticed when i am at a stop when i start to go and am getting into higher RPMs in first gear like right before i shift i get this creaking squekish sound from my driver side rear wheel area. its only on the driver side i believe because if i park my car and push against it and down on it on both sides only the driver side makes the noise. I have no idea what it is.

03-13-2008, 11:18 PM
Oh as far as rear suspension stuff goes i have tokicos, eibach pro kit with no isos, steeda UCAs and LCAsand no quad shocks, and thats it.

03-14-2008, 12:28 AM
I'm willing to bet its those uppers.

03-14-2008, 12:38 AM
That is kinda what i was thinking as far as what would cause the creaking sound but shouldnt both sides do it? And the squeak noise sounds like when to pieces of metal are kinda rubbing. Its kinda hard to describe.

03-14-2008, 07:16 PM
maybe since there's no iso's the springs are making noise? idk why it would only do it in high rpms tho

03-14-2008, 08:38 PM
RPMS was kinda a bad way to put it, its more like when i start moving.

03-15-2008, 10:30 AM
im suggesting the upper bushings. probably old stockers.... :wall:

03-15-2008, 10:33 AM
Mine does the same thing except I dont hear it when I give it a tad more gas than the normal clutch engagement point. My motor/suspension is 100% stock down to its very first pair of underwear.

03-15-2008, 01:26 PM
Thats kinda what iment its like whenthe clutchfully engages it makes the noise.

03-17-2008, 08:31 AM
yep bushings. egh change em'.