1994 Mustang GT Weird Miss

xdkylexd

New Member
Joined
Mar 6, 2014
Messages
11
Reaction score
0
Location
Southern IN
Ok I bought my 1994 GT stock a month ago. It now has 410 gears ac smog egr delete transgo shift kit msd cap rotor coil. I also replaced the plugs fuel and air filter.. Now I have a strange miss between 4-5k it almost completely stops. Also have a surging idle and when I put it in gear it almost wants to die. When its warmed up.
Im going to change to 9mm plug wires.
I checked fuel pressure idling it was at 36psi I dont know where these cars are supposed to be but I have to drop the tank to fix my float anyway.
Any one had an issue like this?
Thanks in advance!
 

CC'S95GT

Post Whore
Joined
Apr 19, 2008
Messages
10,738
Reaction score
172
Location
Hampton ,Ga.
the fuel pressure is supposed about 40psi with the vacuum disconnected.

Whe mine was missing in the upper RPM's, it was the stock coil breaking down.
Surging idle is usually because of a vacuum leak.
 

xdkylexd

New Member
Joined
Mar 6, 2014
Messages
11
Reaction score
0
Location
Southern IN
Well I've been driving it all week.. maybe the plug wires are breaking down

Sent from my DROID RAZR using Tapatalk
 

CC'S95GT

Post Whore
Joined
Apr 19, 2008
Messages
10,738
Reaction score
172
Location
Hampton ,Ga.
Well I've been driving it all week.. maybe the plug wires are breaking down

Sent from my DROID RAZR using Tapatalk

When ever mine runs rough or I get a missfire First thing I go is the basic tune up, Plugs, wires cap and rotor and fuel filter.

Have you ck'd for codes? You can have one set without the CEL being on.
 

xdkylexd

New Member
Joined
Mar 6, 2014
Messages
11
Reaction score
0
Location
Southern IN
Fixed the idle issue found a slew of old cracked vacuum lines replaced them and it idles fine but still has a miss I'm gonna say its plugs that's the only thing I haven't replaced

Sent from my DROID RAZR using Tapatalk
 

Phatboy

Member
Joined
May 27, 2013
Messages
111
Reaction score
0
Mine had a high RPM miss and even though it passed all the testing it turned out to be a bad TPS.
 

Latest posts

Forum statistics

Threads
74,481
Messages
1,447,395
Members
13,362
Latest member
CampTheChamp

Members online

Top