2000 GT Salvage Build

OP
OP
K

KJ-00-GT

New Member
Joined
Aug 19, 2021
Messages
61
Reaction score
107
The calipers have 200 miles?
Yes new calipers, pads and rotors. Had to replace front and rear due to sitting the calipers were stuck when I got it.

So I took it for a test drive today one to check the brakes and two I had a misfire under load that has got worse over time to the point on Saturday it wouldn't hold speed in 5th gear. My neighbor the mechanic used his scan tool and determined that it was cylinder 1, he had a good Ford coil that I put in and that is resolved now.

Back to the brakes, in 10-15 minutes of driving they were dragging again, bad. Back home I checked and could feel the heat coming off the rims, but new twist now the back is also dragging. I'm stumped, thinking something with the master cylinder or ABS module.
 
Last edited:
OP
OP
K

KJ-00-GT

New Member
Joined
Aug 19, 2021
Messages
61
Reaction score
107
Brake problem not fixed yet, going to replace the master cylinder and hopefully that is it.

But still rolling along with projects. Put on a larger throttle body and a cold air intake( Just for the looks on the CAI). Now car doesn't want to idle when started till after a little bit, then fine.


IMG_4202.JPG

IMG_4203.JPG
 

lwarrior1016

Mr. Secondary Timing Chain
Staff
Joined
Sep 22, 2014
Messages
6,930
Reaction score
1,871
Location
South Mississippi
What TB is that? Some are not made as well as others and they try to command too much from the iac. You may have to get a tune to get it sorted out correctly.
 
OP
OP
K

KJ-00-GT

New Member
Joined
Aug 19, 2021
Messages
61
Reaction score
107
What TB is that? Some are not made as well as others and they try to command too much from the iac. You may have to get a tune to get it sorted out correctly.
It's a generic eBay one, 75mm. If it turns out to be too much of an issue I'll just put the stock one back on.
 

07GtS197

Well-Known Member
Joined
Mar 16, 2015
Messages
2,289
Reaction score
740
Location
Naples, Fl
I’ve ran a few of those eBay throttle bodies no problem. Did you set the throttle plate? It could be open (or closed) too far that the iac can’t compensate.
 
OP
OP
K

KJ-00-GT

New Member
Joined
Aug 19, 2021
Messages
61
Reaction score
107
I’ve ran a few of those eBay throttle bodies no problem. Did you set the throttle plate? It could be open (or closed) too far that the iac can’t compensate.
I did mess around with the "Idle" adjustment allen screw, out of the box it wouldn't hold an idle at all, just would die. After I get the brakes fixed so I can drive it again I'll try adjusting it some more.
 

07GtS197

Well-Known Member
Joined
Mar 16, 2015
Messages
2,289
Reaction score
740
Location
Naples, Fl
I did mess around with the "Idle" adjustment allen screw, out of the box it wouldn't hold an idle at all, just would die. After I get the brakes fixed so I can drive it again I'll try adjusting it some more.
Yeah try resetting it when you can. I’ve never had those kinds of issues with cheap throttle bodies myself.
 
OP
OP
K

KJ-00-GT

New Member
Joined
Aug 19, 2021
Messages
61
Reaction score
107
New TB idle issue resolved, the vacuum hose for the IAC had slipped off the tube on the cold air intake and I hadn't notice it. Starts and runs great now and to me seems to have better throttle response.

I still haven't fixed the sticking brake problem yet. I have new master cylinder to install and hopefully that resolves the issue and then I can drive the car again.

On a more positive note I ordered a Quickjack BL5000TL car lift. I've always wanted a lift and was looking at the MaxJack 2 post lift but I couldn't configure it in the shop to not take up to much space with out leaving a car outside at night if I had a car still on the lift. So the Quickjack will still get the car 2 feet in the air instead of 4 feet for the Maxjack, it beats what I have now of floor jack and jack stands.
 
OP
OP
K

KJ-00-GT

New Member
Joined
Aug 19, 2021
Messages
61
Reaction score
107
Small update, I was able to install the new brake master cylinder after much cursing and frustration trying to get the front line attached. I had to remove and then reinstall the strut brace to do this, that added to the time and fun. Saturday did the final bleeding and took it for a drive, went far enough that it would have acted up sticking the brakes and it did not, so looks like I got it fixed. I can drive the car again, woo hoo!

On Saturday after testing the brakes out the car lift came, I'm still working on getting it setup, a wrong connector was sent.

IMG_4232.JPG
 
Last edited:
OP
OP
K

KJ-00-GT

New Member
Joined
Aug 19, 2021
Messages
61
Reaction score
107
After getting back from out of town for a couple of days I finished setting up the Quickjack. So far works great and can fully move around under it with a creeper and still room to work.

It's at full 24" extension here.
IMG_4242.JPG

IMG_4243.JPG
 
OP
OP
K

KJ-00-GT

New Member
Joined
Aug 19, 2021
Messages
61
Reaction score
107
Having the lift now will make the suspension install a lot easier. I started this last weekend, first attacked the rear lower control arms. I have given up on those for now, I can't get the bolts to push out, they are rusted into the bushing sleeves and the sleeves just rotate in the rubber. Not what I wanted but decided to keep going and install the rest of it and get back to the arms some other time or next spring.

Installed the new shocks and adjustable springs in the rear. After lowering it back down to check ride height it sits a 1/4" lower then my wifes 1.5 inch lowered Mustang, I'm good with that and will see where it settles out to. Also found out the drivers side old shock was shot, the quad shocks seem to be bad also.
IMG_4244.JPG

Then started on the drivers front, got that all apart this evening. Having trouble with the nut on top of the strut but resolve that tomorrow. When I pulled the spring out and set it aside I realized the bottom coil was broken off. So two problems I didn't know I had are going to be resolved with the upgrading the suspension.
IMG_4245.JPG
 
OP
OP
K

KJ-00-GT

New Member
Joined
Aug 19, 2021
Messages
61
Reaction score
107
Been out in the shop most of this week. I got the passenger front apart and installed the new coil-over, adjusted ride height to match the drivers side.

IMG_4246.JPG

Turns out both front springs were broken, the bottom full coil.
IMG_4248.JPG

Decided as long I had the rear sway bar out to get rid of the crusty rusty look, sanded it and painted it.
IMG_4249.JPG

Been busy working on this to get it done for what will probably be the last car show I will go to. There are two of them close to me on Saturday, one is a mile away and the other 15 miles. Without a full alignment thinking the close one will be where I go. Going to drive the car tomorrow to check out the ride and I have a couple of more things I could do to the car but may hold off on those for now.
 
OP
OP
K

KJ-00-GT

New Member
Joined
Aug 19, 2021
Messages
61
Reaction score
107
I ended up going to the further away car show so good drive to really check out the suspension. It really needs the alignment but other then that I'm very happy with the Maxspeedingrods coilover's, I guess the back isn't really a coil over more of an adjustable spring cup. I'm very happy with the way it rode, it's firm not bouncy, handle's great. Exactly what I wanted and expected. I did not slam the car it's only about 2' lower so I still a good amount of shock travel in the rear and front . I adjusted the rebound at 12 clicks out of 24.

I also as long as I had it up in the air this week did some surgery on the stock mufflers, it now sounds just like I wanted very throaty but not raspy and no drone at highway speed.

IMG_4256.JPG
 
Last edited:

Latest posts

Forum statistics

Threads
76,099
Messages
1,470,375
Members
14,068
Latest member
SinCitySN95

Members online

Top