96 cobra

Discussion in '96-04 - 4V Specific' started by collinselectric5, Oct 20, 2016.

  1. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    Hi, I just purchased a 96 cobra that runs pretty good given it has 200,000 miles! There's some little things here and there that need repair but it was only $1000. I've always wanted a cobra and my budget isn't enormous so I thought I'd give it a shot. Just looking for some feedback if I should just run it till it eventually dies or put some actual money into it. Thanks!

    Sent from my SM-J700T1 using Tapatalk
     
  2. PinkieT

    PinkieT Well-Known Member

    Messages:
    1,644
    Likes Received:
    386
    Joined:
    Jun 22, 2015
    Location:
    Cleveland
    Depends what it needs. Sounds like a lot of fun for not a lot of money, though. Enjoy!
     
  3. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    Yeah, I figure if it does go on me within a year, it's not a major setback for some fun

    Sent from my SM-J700T1 using Tapatalk
     
  4. 4.6Stangrage

    4.6Stangrage Member

    Messages:
    148
    Likes Received:
    0
    Joined:
    Jul 16, 2013
    Location:
    Jamestown, California

    Pics or it didnt happen ;)
     
  5. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    I'll have pics later today or tomorrow

    Sent from my SM-J700T1 using Tapatalk
     
  6. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    Just replaced my maf and cleared the check engine light yesterday, but last night after filling the gas tank my oil pressure did not move at all. Checked the oil and bone dry and found oil all over the bottom of the engine, it was coming from the oil pressure sender switch. I replaced it with no more leaking but my pressure gauge isn't moving at all. Any ideas why?

    Sent from my SM-J700T1 using Tapatalk
     
  7. 96blak54

    96blak54 Legend

    Messages:
    7,469
    Likes Received:
    779
    Joined:
    Feb 21, 2011
    Location:
    Ky
    Did you hook it up? ....lol.

    What a smartass I am, but really did you remember to hook it up. Some of the most simplest things get us car guys.....like an empty gas tank when it wont start.
     
  8. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    I swore I hooked it back up but now u got me second guessing lol... I'll check in a bit

    Sent from my SM-J700T1 using Tapatalk
     
  9. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    Yeah it was hooked up

    Sent from my SM-J700T1 using Tapatalk
     
  10. Musturd

    Musturd Legend

    Messages:
    9,111
    Likes Received:
    598
    Joined:
    Feb 12, 2011
    It will be knocking right quick if it's not building oil perssure but with the mileage the timing chain tensioners may have worn out and and shavings rundown the cover and clog the pick up .
     
  11. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    It just seemed strange that before I had the issue with the pressure switch the gauge was working.

    Sent from my SM-J700T1 using Tapatalk
     
  12. SnakeBit!

    SnakeBit! Active Member

    Messages:
    799
    Likes Received:
    68
    Joined:
    Mar 6, 2014
    Location:
    Florida
    be sure you got the right one. sometimes the parts place will sell you one that is supposed to be it, but it isn't. friend of mine went thru that.
     
  13. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    I'm just gonna get another when I change the oil in a couple weeks, it's been running fine just having a dead gauge is annoying.

    Sent from my SM-J700T1 using Tapatalk
     
  14. SnakeBit!

    SnakeBit! Active Member

    Messages:
    799
    Likes Received:
    68
    Joined:
    Mar 6, 2014
    Location:
    Florida
    also, since the sending unit was leaking so bad, make sure the connector is not covered in oil and not making contact. as indicated before, my friend got a new one from one of the parts places and it did the same thing...showed 0. got the right one from Ford and no issues.
     
  15. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    When I bought this cobra the abs light was on and I'm assuming the wire hanging near my rear tire could b the reason. I couldn't find a male connector end just female ends for sale rather than buying the whole thing. Does anybody know where I can buy one?

    Sent from my SM-J700T1 using Tapatalk
     
  16. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    [​IMG]

    Sent from my SM-J700T1 using Tapatalk
     
  17. SnakeBit!

    SnakeBit! Active Member

    Messages:
    799
    Likes Received:
    68
    Joined:
    Mar 6, 2014
    Location:
    Florida
    salvage yard.
     
  18. collinselectric5

    collinselectric5 Member

    Messages:
    173
    Likes Received:
    0
    Joined:
    Oct 20, 2016
    Ahh, didn't think of that. Thankyou!

    Sent from my SM-J700T1 using Tapatalk
     
  19. SnakeBit!

    SnakeBit! Active Member

    Messages:
    799
    Likes Received:
    68
    Joined:
    Mar 6, 2014
    Location:
    Florida
    yep, should be the same for most of the sn 95 cars and if I am not mistaken, 94-04 will be the same. we have a lot of cars in one of our junkyards of mustangs, usually at least 5 or 6 in there at once.
     
  20. evilcw311

    evilcw311 Most Evil Mod! Staff Member Staff

    Messages:
    7,176
    Likes Received:
    1,788
    Joined:
    May 9, 2010
    Location:
    Louisville, KY
    What's abs? :)


    Sent from my iPhone using Tapatalk