96 mustang gt running really rough.

Discussion in '96-04 - 2V Specific' started by thatone1320copcar, Oct 7, 2016.

  1. thatone1320copcar

    thatone1320copcar New Member

    Messages:
    35
    Likes Received:
    0
    Joined:
    Oct 7, 2016
    Just purchased a 96 mustang gt off of a buddy of mine, it was running really rough got a good deal on it. Towed it home, dead battery. new battery its running really rough. said it wasn't running like that since he changed the lower intake manifold. he used an npi intake on npi heads so no issue there. i pulled the plugs and cylinder 4 and 8 boots were rusted on. bottom of plug 8 was rusted in cylinder. replace all plugs and wires with Motor craft replacement parts plugs are gapped to .54 its throwing codes p1443 p0401 p0303 p0306 and it has the same codes with pd after them. had a very small amount of 2 year old gas in it, ran cleaner through it with a fresh tank of chevron 91 octane. also seafoam'd with new gas, seamed to help the problem but its still misfiring and running really rough. plastic vacuum hose going to EGR is cracked and there is another plastic vacuum line that is cracked a well that will be getting replaced.
     
  2. DropTopPony

    DropTopPony Administrator Staff Member Admin SN95 Supporter

    Messages:
    15,342
    Likes Received:
    119
    Joined:
    Jan 12, 2006
    Location:
    South Jersey
    Did you replace the fuel filter? Mine started running like crap when the filter needed to be swapped. Old gas was what did mine in I think.
     
  3. the5.ohh

    the5.ohh Legend

    Messages:
    9,555
    Likes Received:
    108
    Joined:
    Oct 15, 2012
    Location:
    Shaolin, NY
    Definitely change the fuel filter.
     
  4. thatone1320copcar

    thatone1320copcar New Member

    Messages:
    35
    Likes Received:
    0
    Joined:
    Oct 7, 2016
    have not changed fuel filter, not sure if previous owner did either. going to change pcv valve today as well
     
  5. thatone1320copcar

    thatone1320copcar New Member

    Messages:
    35
    Likes Received:
    0
    Joined:
    Oct 7, 2016
    anyone know firing order? and what plugs go where on coilpack? judging by the diagram on the coilpacks themselves the wires may not be correct, i installed the new ones exactly how previous owner had them
     
  6. PinkieT

    PinkieT Well-Known Member

    Messages:
    1,629
    Likes Received:
    373
    Joined:
    Jun 22, 2015
    Location:
    Cleveland
    I replaced my wires and coils and had two switched plug wires. The engine would sputter but couldn't stay running.
     
  7. 07GtS197

    07GtS197 Well-Known Member

    Messages:
    1,390
    Likes Received:
    186
    Joined:
    Mar 16, 2015
    Location:
    Naples, Fl
    The firing order is 13726548 but on the coils 5 and 6 are switched for some reason so be careful. The egr valve would not affect idle unless its stuck open. What other vacuum line is cracked? Also check the rubber part of the vacuum line coming off the pcv valve. Our motors pull a lot of oil through the pcv valve and it degrades that rubber line over time.