A lot of questions.. idle/boost/power

Discussion in 'Forced Induction & Tuning' started by TheBab, May 10, 2007.

  1. TheBab

    TheBab Active Member

    Messages:
    638
    Likes Received:
    0
    Joined:
    Feb 21, 2007
    First off let's start off with car and mods..


    1998 Cobra with the following on it...

    - Engine - Engine was bored 0.030 over, Manley H-beams, DSS blower pistons with 8.5-1 compression.
    - Vortech S-Trim Supercharger w/ 3.33 pulley
    - 24" x 12 " x 3 Polished front mount intercooler
    - 42lbs. injectors with a lightning 90mm Mass air meter
    - Walboro 255 fuel pump with T-rex pump
    - Flowmaster mufflers
    - Bassani X-pipe
    - FRPP shroty ceramic coated headers


    I have a few questions ....

    Boost Question

    It was seeing 10 psi before the intercooler install....I installed the intercooler during the winter so I couldn't go test it out... but all my clamps are tightened down damn good so I'm 99% sure theres no leaks..... all I am seeing is 5 psi at 6,000 rpms... I knew I was going to lose some boost but 5 lbs of boost? Any ideas on what this could be besides intercooler? Anything I should check?

    Idle Question

    When I turn the car on.. it idles high for a second.. but then drops back down to about 1000 rpms... it wont go below that... Shouldn't it be lower? Is there a way to set it?

    Then when I am driving around.... and I come to a stop... put the car in neutral... or even in gear... at a complete stop and clutch all the way in... the car will idle at like almost 2K rpms... for like 10 seconds or so... then drop back to normal idle (well my normal idle of 1k) .... what could cause this?


    RPMs question

    I bought the car with the vortech and tuning done already.... I got the charts.. but the dyno was shut down at 6k rpms when it redlines at roughly 6800 or so... If I try to take it above 6k it falls on its face... I'm not sure why this is... my only thought was I am pegging the maf? Any clues?


    Yes, I know A LOT of questions... but I just want to make sure I can get this car running great... I appreciate any help or answers.


    Thanks,
     
  2. Fros97GT

    Fros97GT New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Feb 15, 2007
    I dont know what would be different on the Cobra....might want to ck for vac leaks
    Also my idle hangs on GT...I havent gotten around to mine yet, but everybody tells me its a dirty or bad PCV valve causing idle hang
     
  3. Thomas_W

    Thomas_W Well-Known Member

    Messages:
    1,478
    Likes Received:
    44
    Joined:
    Jan 25, 2007
    Location:
    Capon Bridge, WV
    Depending on what brand intercooler it is, it could be the intercooler. I have heard of some "ebay" intercoolers loosing 3+ psi on cars b/c they are so restrictive, especially if its a tube and fin style (radiator basically) compared to the bar and plate versions. Also, is there any head porting done? If so this will also cause a drop in boost pressure b/c the motor is more efficient. Boost is basically a measurement of airflow restriction


    Mine does the EXACT same thing. I've come to accept this as normal for now since i am untuned. With a proper tune, it shouldn't hang for so long i suppose.



    If they didn't take the car above 6k rpm's there's a reason for it. You probably aren't pegging the maf, as if you are, the car acts like it is hitting the rev limiter and just wont rev any higher.

    My guess is, its not getting enough fuel above 6k rpm's and thats why it falls on its face.
     
  4. TheBab

    TheBab Active Member

    Messages:
    638
    Likes Received:
    0
    Joined:
    Feb 21, 2007
    It is in fact a SSAutoChrome intercooler........

    It's suppose to be a bar and plate...
     
  5. Thomas_W

    Thomas_W Well-Known Member

    Messages:
    1,478
    Likes Received:
    44
    Joined:
    Jan 25, 2007
    Location:
    Capon Bridge, WV
    i've heard of some SSautochrome's being complete crap before. I've also seen some IC's advertised as Bar and plate and actually be tube and fin.


    Bypass the IC w/ a piece of the correct size tubing and see if you get the same boost pressure back. If you do, its the IC, if not.. then its something else, possibly a boost leak in a weld, coupler or bypass valve.
     
  6. scarface

    scarface Guest

    MIne did the same Idle problem when the IAC was connected to the Pressure pipe (after supercharger). I move the hose down to the power pipe (pre-supercharger) and idle issues went away.
     
  7. TheBab

    TheBab Active Member

    Messages:
    638
    Likes Received:
    0
    Joined:
    Feb 21, 2007

    Rog, I have a feeling when I bypass the FMIC my boost issues will be fine... in which case... I'll have to sell the FMIC and buy a better one. :slap:\


    Thanks for the help guys....
     
  8. ripper

    ripper Well-Known Member

    Messages:
    3,323
    Likes Received:
    0
    Joined:
    Jan 2, 2007
    My car had the same idle rpm issues as yours. It was all fixed in the tune. We took 35% off the IAC in the tune and it idles perfect and falls right off when you let off the gas. Your boost problem i have no idea but sounds to me like Tom is right. If it changed after the IC install than thats probubly what did it.