AFR change...running rich

Discussion in '96-04 - 2V Specific' started by Scud2, Oct 3, 2016.

  1. Scud2

    Scud2 New Member

    Messages:
    45
    Likes Received:
    0
    Joined:
    Sep 6, 2016
    Location:
    Cleveland, Ohio
    So I have tried to do a little research and have not found much. Recently I noticed on my 2001 GT with a vortech V3 my afr used to be 11.5-11.7. However recently my afr dropped to low 10's. I really did not change anything. I did take off my discharge tube and changes the iat sensor about 12 inches closer to the throttle body. But would that really affect everything like that? I replaced everything and it is all tight. I have no other ideas for what it could be. COP? Bad plug? Would that cause my wideband to read rich? Any help would be appreciated! Also no codes have been thrown yet.
     
  2. Scud2

    Scud2 New Member

    Messages:
    45
    Likes Received:
    0
    Joined:
    Sep 6, 2016
    Location:
    Cleveland, Ohio
    Nevermind it's the iat sensor. My bad. Tried changing it back and all is good!
     
  3. whiplash473

    whiplash473 Moderator Staff SN95 Supporter

    Messages:
    12,251
    Likes Received:
    1,205
    Joined:
    May 12, 2012
    Location:
    Northern IL
    The PCM reads everything. It doesn't surprise me that it's back to normal, good to hear you got it fixed though.
     
  4. Scud2

    Scud2 New Member

    Messages:
    45
    Likes Received:
    0
    Joined:
    Sep 6, 2016
    Location:
    Cleveland, Ohio
    I am going in for a new tune to tweeked a few things. Plus I am 90% done with adding meth injection. I'll finish it today ro tomorrow...Thursday is my appt to get it tuned. I want 400 so bad. I had 376 at 5500 rpm. If he takes it to 6k I should make it especially with meth!