am I hearing things?

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
27,926
Reaction score
3,727
Location
Evansville Indiana
My blower started making noise, or at least I started to notice this noise.



I checked the oil and it looked good and then took the belt off and it seems to turn and sound normal.



Now that I think about it I didn't really look at the pulleys behind the blower just because it seemed to be coming form it, but it could have been below it.

It also has become louder on the drivers side and not sure why. I went under it and checked all the bolts on the exhaust and they are all tight and today I tightened up the header bolts just a tad on the drivers side, I will do the same on the pass side tomorrow but I don't think that would make it louder. I am wondering about the new cats I put on it and wondering if something went wrong with one of them...
 
Last edited:

lwarrior1016

Mr. Secondary Timing Chain
Staff
Joined
Sep 22, 2014
Messages
6,266
Reaction score
1,294
Location
South Mississippi
You might have to run it more and grab a mechanics stethoscope to pinpoint the sound more. It kind of sounds like an alternator that has a bearing failing. The kind of clicking/roaring sound.

The second video with you turning it by hand, is it supposed to sound like that? It sounds like it’s dragging to me. I though they were supposed to spin freely like a turbo.
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
27,926
Reaction score
3,727
Location
Evansville Indiana
The blower always had a little bit of resistance and a slight noise when turned by hand, if I remember correctly but its been a while. I would not be surprised that the alt right next to it is making the noise and I am just looking at the blower. I had already decided last night to take the belts off and try spinning all the pullets to see since it doesn't take long. I bet that big old alts bearing are going bad...
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
27,926
Reaction score
3,727
Location
Evansville Indiana
its not the alt, or any of the pullies up front. The power steering pump makes a little noise but nothing that I would not expect. Idunno I checked the blowers oil and now everything around it so I guess I will send it and hopefully not revisit this topic in the future...
 

RAU03MACH

Well-Known Member
Joined
Apr 23, 2019
Messages
3,219
Reaction score
2,605
Location
NEW MEXICO
Not leaking around the pulley shaft
Maybe the front bearings are not getting oil
Had a Paxton that happened like that
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
27,926
Reaction score
3,727
Location
Evansville Indiana
I noticed I had a couple of drops under the oil drain line for the blower but I tightened it up and it stopped. Any chance while it has oil its just a little low? Is it possible to overfill a vortech?
 

RAU03MACH

Well-Known Member
Joined
Apr 23, 2019
Messages
3,219
Reaction score
2,605
Location
NEW MEXICO
I would say yes
In my book for the Kenny bell it has warnings in 2 places not to overfill
And on the charger it's self
My Paxton had over fill labels as well
 

Latest posts

Forum statistics

Threads
74,993
Messages
1,454,234
Members
13,628
Latest member
reedj304

Members online

Top