Auto Trans Problem - Stuck in Park on my AOD - '96 GT

Discussion in '96-04 - 2V Specific' started by Sir Charles, Jul 11, 2007.

  1. Sir Charles

    Sir Charles New Member

    Messages:
    90
    Likes Received:
    0
    Joined:
    May 28, 2007
    :help2:


    Well I have changed out the Stoplight switch and the brake/neutral cable and it hasn't changed anything. I checked all of the fuses also just to play it safe and the problem is still there.

    No brake lights, turn signals and it won't shift out of park.
     
  2. Sir Charles

    Sir Charles New Member

    Messages:
    90
    Likes Received:
    0
    Joined:
    May 28, 2007
    After changing out the cable and replacing the stoplight switch, the problem still exists. Come to find out that the wire harness in my steering column is fried. So we will see what this does after I replace it.
     
  3. nyuk98gt

    nyuk98gt Member

    Messages:
    128
    Likes Received:
    0
    Joined:
    Nov 1, 2006
    Sir Charles:

    You've done all the right (logical) things. If it won't move with the key turned to on (all the warning lights come on but not cranking the car), then the only thing I can think of is that the spring is broken in the shifter handle and it is jamming the button. Before you do what I mention below, run a search at TCCoA.com, the T-Bird & Cougar site -- the folks there have had plenty 'o trouble with shifter buttons sticking and have figure out the best ways to fix the various problems.

    OK, if you don't find anything helpful at TCCoA.com, then it is time for surgery. There is a tiny allen screw in the front of the handle. You can feel it, just under the tee branch where the handle begins to taper and it is right in the center. First, remove the trim cowl by pulling it up (gently) to expose the shifter base and OD wire. Feel under the base and try to disconnect the OD wire from the connector. It is a pain. Next, you'll have to manoeuver an allen key in there and, once it is loose (don't take it out all the way or drop it), gently pull up and twist the handle. Don't yank up too hard or you'll snap the OD wires (they are very thin). With the handle loose, you should be able to see if the button in the handle is stuck or if the white button on the top of the shifter is stuck. Either one of these will cause the problem you are experiencing.

    HTH,

    Chris

    edit: lol, I just read your 2nd post. I think you've found the real problem. So, .... nevermind... ///end of edit
     
  4. Sir Charles

    Sir Charles New Member

    Messages:
    90
    Likes Received:
    0
    Joined:
    May 28, 2007
    It looks like the wire harness was it but now I have a different problem. The radio no longer has power so obviously it is another wiring problem. After the wire harness was swapped out, the brake lights, turn signals worked and it was able to shift out of park.
     
  5. Sir Charles

    Sir Charles New Member

    Messages:
    90
    Likes Received:
    0
    Joined:
    May 28, 2007
    So everything works now. It just chaps my hide when it boils down to a sensor. I had my A/C check out today and it was working because of a $28 dollar sensor.
     
  6. nyuk98gt

    nyuk98gt Member

    Messages:
    128
    Likes Received:
    0
    Joined:
    Nov 1, 2006
    Good deal, everything is working! Go and enjoy. :thumb:

    Chris