Automatic transmission stuck in drive

IBsenoj

New Member
Joined
Aug 24, 2021
Messages
2
Reaction score
2
Location
Utah
Hi y'all. I'm new here, thank you in advance for reading this long post.

I have a POS 1994 V6 (sad) Mustang I bought for $300. I'm starting to think restoring it isn't a good idea. Can someone confirm my suspicion?

[unimportant backstory] A year ago when I bought this it had been sitting for 8 straight years in the original owner's backyard. The car was his baby since he bought it new, sadly it was returned to him trashed after lending it to his daughters for college. He then parked it due to its state. When I got it from him I had to tow it home, and from there I realized the whole entire fuel system had to be replaced. 8 years of ethanol gas was not good to that car... I replaced the tank, pump, fuel rails, and I had to clean the crap out of the fuel lines and injectors. [/unimportant backstory]
After that, the car ran, but I was immediately disappointed to see that once I threw her into drive nothing happened, turns out it was a whole gallon short on trans fluid (Oddly enough, the gravel where the car had sat for 8 years had zero leak stain spots). Anyways, after getting it running and driving I soon parked it at my work's warehouse until I had more time to make it pretty again. Now we're here, one year later, the new battery was completely dead, I jumped it with my trusty ranger, and then it wouldn't move under power in any gear; reverse, drive, 1st, 2nd, nothing. After messing around and cycling through each selection I noticed Reverse had a slight reaction, so after eventually flooring it, it barely rolled out from where it was parked. Here's a link to me getting it to start and then trying to back it out from where I parked it a year ago. (see desc.)
The car was suddenly leaking coolant (which it did not do before-maybe a wild cat chewed on a line), and there was a burning smell. After turning it off and calling some friends over we put more transmission fluid in it. I turned it back on and managed to drive the car in drive, I was giddy about having a car that moved so I whipped it around the warehouse a couple of times, and then when I came to park it I slid the selector into park, but the transmission was still in drive. Then I tried giving it gas in reverse, and it just stayed stationary (could it have been in drive and reverse at the same time? yikes), then I put it back into drive and it rolled forward with some gas, just like before. I selected park, although the tranny was still in drive, and turned her off. My friends and I went to push the car to a better spot, but the tranny was locked, we had it in neutral but the car had less give than it does in park, it wouldn't really move at all! The engine was rocking like it was directly connected to the wheels like a manual parked in 1st gear.
We decided to drop the tranny pan and change the horrible-smelling trans fluid and filter. I attached the before and after of the pan (not good). After doing this nothing changed. The car only moved when drive was selected. I parked it and called it a night.

What do you guys think? Could it still not have enough trans fluid in some places like the torque converter or something? Or is the tranny trashed? If it is, I'm going to cut my losses and junk this car, and return the new convertible top while I still can.
IMG_4328.jpg
 

lwarrior1016

Mr. Secondary Timing Chain
Staff
Joined
Sep 22, 2014
Messages
6,185
Reaction score
1,238
Location
South Mississippi
Man, I really think you need another transmission. These transmissions are really bad about breaking to snapping off the forward drum. If it happens just right, it could lock the forward clutch up so it can’t release. Normally it’ll break the snap ring and forward won’t work. Either way, the fluid being burnt and that debris on the magnet, that transmission needs to be rebuilt.
 

IBsenoj

New Member
Joined
Aug 24, 2021
Messages
2
Reaction score
2
Location
Utah
Man, I really think you need another transmission. These transmissions are really bad about breaking to snapping off the forward drum. If it happens just right, it could lock the forward clutch up so it can’t release. Normally it’ll break the snap ring and forward won’t work. Either way, the fluid being burnt and that debris on the magnet, that transmission needs to be rebuilt.
Thanks @lwarrior1016 & @white95
deep down I knew that it was toast. I just needed someone else to tell me. Maybe I'll do a 5 speed swap...

Thanks again.
 

Latest posts

Forum statistics

Threads
74,871
Messages
1,452,371
Members
13,557
Latest member
afield00

Members online

Top