Bad Alternator?

Discussion in 'The Garage' started by sn95jones, Nov 13, 2015.

  1. sn95jones

    sn95jones Well-Known Member

    Messages:
    4,035
    Likes Received:
    210
    Joined:
    May 29, 2011
    Location:
    Arlington, Tx
    This is on my new 06 GT with 60k miles...
    Seems like at around 3500rpms the battery gauge spikes and all accessories will cut off until the rpms drop then everything comes back on. By accessories I mean: Radio, interior lighting, and fog lights.
    Seems to have a new-ish alternator.
    Current mods are:
    Ford Racing CAI
    BBK 62mm throttle body
    SLP exhaust
    Sequential turn signals
    Push button start.

    Could it be a defective voltage regulator in the alternator?
     
  2. CC'S95GT

    CC'S95GT Post Whore

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    That would be the first place I'd look too.
    Pull it and have it tested.
     
  3. evilcw311

    evilcw311 Most Evil Member! SN95 Supporter

    Messages:
    7,459
    Likes Received:
    2,080
    Joined:
    May 9, 2010
    Location:
    Louisville, KY
    That's exactly what mine did when the regulator went bad. Made my headlights and dash lights look like they were gonna explode cause they'd get so bright.


    This message courtesy of crapatalk!
     
  4. ttocs

    ttocs Post Whore

    Messages:
    26,112
    Likes Received:
    2,909
    Joined:
    Oct 9, 2009
    Location:
    Evansville Indiana
    wut they said
     
  5. sn95jones

    sn95jones Well-Known Member

    Messages:
    4,035
    Likes Received:
    210
    Joined:
    May 29, 2011
    Location:
    Arlington, Tx
    Y'all were right, it was in fact the alternator. Thankfully it had a lifetime warranty :)