Beating a dead horse, New IAC, high idle

Discussion in '96-04 - 2V Specific' started by Shouter, Apr 4, 2015.

  1. Shouter

    Shouter New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Mar 24, 2015
    Location:
    Fargo, ND
    Well last night while cruising, my car developed a high 1500rpm idle. It lasted for about 10 seconds, then went right back down to 500. Before that I've been noticing a hanging idle, all I took the iac off and noticed it was full of carbon. This morning I bought a new unit, put it on, cleaned my throttle body, and fired it up. It's maybe worse now. I push the clutch in and it raises a few hundred rpms, drops to 1500, stays there for awhile before settling back down to 500. Any ideas here?

    I have an Accufab throttle body and plenum, bbk cold air intake, and exhaust on the car with an sct eliminator chip.

    This is really annoying.
     
  2. lwarrior1016

    lwarrior1016 Moderator Staff SN95 Supporter

    Messages:
    5,660
    Likes Received:
    680
    Joined:
    Sep 22, 2014
    Location:
    South Mississippi
    That is really annoying, i was battling a high idle on my car. Have you checked for vacuum leaks? Also, have you made sure your throttle body is going all the way closed? I know sometimes you get some build up in just the right spot and it make the blade not want to close all the way.
     
  3. ttocs

    ttocs Legend

    Messages:
    25,508
    Likes Received:
    2,508
    Joined:
    Oct 9, 2009
    Location:
    Evansville Indiana
    Check for vacuum leaks or loose connections on the intake.
     
  4. chris91

    chris91 Well-Known Member

    Messages:
    3,761
    Likes Received:
    198
    Joined:
    Apr 20, 2007
    Location:
    Cincinnati, OH
    What brand of IACV did you buy?
     
  5. Shouter

    Shouter New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Mar 24, 2015
    Location:
    Fargo, ND
    Don't remember, it's from oreillys. I had it on the scan tool and ran the diagnostics for iac, and it seems to perform normally. What is weird, when I'm in idle speed diagnostic mode, I can manually adjust the iac value(%). When I set it at 50%, it behaves perfectly, rev it up, it comes right back down. It is when I leave diagnostic mode and the iac values change per throttle position when it slowly decreases rpm and hangs at 1500 for a long time, then drops down to almost killing it (100rpms) then catches up to idle at 600. No codes thrown, tps performs as it should, etc. I just cleaned the throttle body, so I might of missed a spot. Also sprayed carb cleaner around the post MAF vacuum lines, no change.
     
  6. 96blak54

    96blak54 Legend

    Messages:
    7,485
    Likes Received:
    804
    Joined:
    Feb 21, 2011
    Location:
    Ky
    Could be a faulty tps. Problem chacing sux!
     
  7. Shouter

    Shouter New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Mar 24, 2015
    Location:
    Fargo, ND
    As stated, the tps voltage seemed to rise and fall steadily with throttle
     
  8. Shouter

    Shouter New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Mar 24, 2015
    Location:
    Fargo, ND
    Also, when I disconnect the iac, the rpms noticeably drop. Plug it back in and it revs up, then after a few seconds drops back to idle
     
  9. Pack Rat

    Pack Rat New Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    Mar 18, 2015
    In my experience it is Motorcraft of nothing on ISC motors. After market dont last. 15 years Ford tech. 20 year running my own shop.
     
  10. Shouter

    Shouter New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Mar 24, 2015
    Location:
    Fargo, ND
    Okay this is a video of the car on the scan tool, in the Idle Speed Control test mode. I manually can adjust the IAC valve, and it responds to changes as it should. When I set the IAC to 50, it will idle exactly where I want it, and rev up nice, and come right back down. Now I don't know what this is an indication of, but I figured it might help someone come up with an idea.
    [​IMG]
     
  11. Shouter

    Shouter New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Mar 24, 2015
    Location:
    Fargo, ND
    "Double Post" but here is a video of me driving. I let off the throttle, push the clutch in, and coast to a stop. You notice its symptoms immediately. It hangs, then drops below its desired idle before catching up and idling where it should be
    [​IMG]