Bryan's 96 GT Vortech Build

OP
OP
B

BMAC96GT

Active Member
Joined
Nov 12, 2009
Messages
967
Reaction score
54
Location
Virginia
Are you hiding the coils under the intake? that's genius! The color is awesome btw
Thanks! And yes, coil packs, plug wires, and main engine harness are all ran under the intake.

I’m not a fan of blue but wow that color is killer! Love the build! Digging the shaved valve covers! Question? What fittings are those in the pcv ports, and did you just run them over from one another or do you have a catch can?
The valve covers I used are OEM valve covers off of a later model Crown Vic/Town car ('05 model I believe), so the PCV fittings were a little different than my '96. I pulled the PCV fittings out of the valve cover, drilled and tapped the holes for -10AN and used Earl's Performance AT985010ERL fittings in each hole. They're a o-ring style fitting and they worked great. I have both -10AN lines running to a Motion Raceworks vented catch can mounted to the intake behind the plenum

DQJgFbCQ.jpeg
 

d.garza18

Active Member
Joined
Jun 23, 2017
Messages
634
Reaction score
118
Location
TEXAS
Thanks! And yes, coil packs, plug wires, and main engine harness are all ran under the intake.


The valve covers I used are OEM valve covers off of a later model Crown Vic/Town car ('05 model I believe), so the PCV fittings were a little different than my '96. I pulled the PCV fittings out of the valve cover, drilled and tapped the holes for -10AN and used Earl's Performance AT985010ERL fittings in each hole. They're a o-ring style fitting and they worked great. I have both -10AN lines running to a Motion Raceworks vented catch can mounted to the intake behind the plenum

View attachment 14988
That is sick! Makes me want to do that to miine! I’m still using the 96 valve covers but their shaved
 
OP
OP
B

BMAC96GT

Active Member
Joined
Nov 12, 2009
Messages
967
Reaction score
54
Location
Virginia
I’ve done a horrible job at updating this thread and this has been long overdue. Long story short, the car is running and driving perfectly. Had a kid in May so really haven’t messed with the car a lot since then, but was able to get it back together and remote tuned. Tune is super soft, but the car runs great. I’ll try to make some posts here updating on what all I did to get it to where it is now. The car still needs to be dyno tuned, and I still need to wetsand and buff the whole car to get the paint like I want it, and plenty of other little odds and ends
 
Top