Car temp goes from cold 2 hot

Discussion in '94-95 5.0 - Specific' started by 1Fast92FiveOh, Jun 19, 2007.

  1. 1Fast92FiveOh

    1Fast92FiveOh New Member

    Messages:
    56
    Likes Received:
    0
    Joined:
    Feb 21, 2007
    I have a 94 GT and when I start the car and after it runs for 5-10 mins the temp gauge from cold to red hot. I opened the hood and it doesn't seem to be over heating. I'm think just take the proper percausions and switch to a fluidyne radiator and a new thermostat.

    Would you guys reccomend anything else. Also what degree thermostats come stock on these cars?
     
  2. Suspect

    Suspect Well-Known Member

    Messages:
    2,776
    Likes Received:
    1
    Joined:
    Jan 13, 2006
    Location:
    ATL
    have u messed with anything lately? might just be some trapped air, burp it. could also be ur guage or the temp sender.

    i think they come with 195*, but ive been using a 180* after installing my fluidyne.
     
  3. quickstang_1994

    quickstang_1994 Well-Known Member

    Messages:
    2,208
    Likes Received:
    12
    Joined:
    Apr 30, 2006
    Location:
    Cross Anchor, SC
    make sure it has coolant in it and not just in the overflow(sometimes it doesn't transfer). Stock cooling system handles 500rwhp.
     
  4. 1Fast92FiveOh

    1Fast92FiveOh New Member

    Messages:
    56
    Likes Received:
    0
    Joined:
    Feb 21, 2007
    So I bought a 180* Thermostat, went to switch it, it already had one. Well I changed it with my new Mr. Gasket thermostat and low and behold, it is now running a lot cooler