Check Engine Light tripped again :(

Discussion in 'The Garage' started by 96SVTCobra, Jul 26, 2006.

  1. 96SVTCobra

    96SVTCobra New Member

    Messages:
    52
    Likes Received:
    0
    Joined:
    Jul 9, 2006
    Ok, I've got an off road BBK h-pipe. Installed the MIL elminators. Check engine light went off. Ran fine for about 4 months like that, but since this April, the check engine light will go off for a few days and come back on for a few months. Any ideas? Car is next to stock. I'm getting ready to buy a nitrous kit and want to get this problem out of the way before that.
     
  2. wopony98

    wopony98 New Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    Jun 5, 2006
    :hammer: Damn I thought my Cobra was the only one that did that. My 98 light comes on and usually stays on for a couple of days to a week or two. Then it will go off and stay off for a couple of days then come back on. The time actually varies a lot as to how long it stays off and on.

    I use to think it was because I ran the car hard or when I got on it. I however don't think this is the issue. Hope someone knows.

    You can always take it to Advance Auto and they can hook up a diagnostic scanner and tell you what the code says it is that is causing it.
     
  3. Is your exhaust leaking?
    maybe a bad O2 sensor...

    Thats the only thing I could think of given your mods... and I have a feeling that you do indeed have a leak ;)
     
  4. 96SVTCobra

    96SVTCobra New Member

    Messages:
    52
    Likes Received:
    0
    Joined:
    Jul 9, 2006
    man I hope not. Guess I'll jack it up and tighten everything back up... = pain in the ass. I used an air wrench and everything!
     
  5. Matt94GT

    Matt94GT Legend Retired Staff SN95 Supporter

    Messages:
    11,861
    Likes Received:
    58
    Joined:
    Jan 10, 2006
    Location:
    Victoria, British Columbia, Canada
    im guessing its somthing to do with the 02s/mil elimators...
     
  6. jpajkos

    jpajkos Active Member

    Messages:
    622
    Likes Received:
    0
    Joined:
    Jun 20, 2006
    Clean the mil's then hook up an OBDII reader get the code. Mine was doing that then i found out it was my gas cap!. Bought a new gas cap and it never came back on.
     
  7. 96SVTCobra

    96SVTCobra New Member

    Messages:
    52
    Likes Received:
    0
    Joined:
    Jul 9, 2006
    hmmm it turned itself off tonight... definitely need it looked at. Stupid computer!
     
  8. tomustang

    tomustang New Member

    Messages:
    46
    Likes Received:
    0
    Joined:
    Jan 15, 2006
    get the code scanned
     
  9. Iceman12

    Iceman12 New Member

    Messages:
    30
    Likes Received:
    0
    Joined:
    Jan 24, 2006
    My car does that too, although it now spends more time with the light off than on anymore. From what I've seen it has a lot to do withe th temp and humidity on my car. When it gets real hot out my car tends to run a lil rich, so the CPU notices it has no cats, but for example:

    if I drive to my friends house when it is real hot and humid and the light comes on, if i hang out there till it gets dark and cool, and the car completely cooled down, (when temp goes back below 160 the CPU will take another look at O2 data and re-decide if it will use it, MIL light on = not using O2 data), once the car warms back up ususally the light will go off again.

    So with a lil planing I can now pretty much keep the MIL light of all the time, which at least on my car makes it run a lot better.
     
  10. 96SVTCobra

    96SVTCobra New Member

    Messages:
    52
    Likes Received:
    0
    Joined:
    Jul 9, 2006
    my thoughts exactly. it's been under 105 here recently (it was over 105 when the light tripped) and it's been off ever since. Though humidity seems to have no effect on it. As tonight, it was 93% humidity and 90 degrees and no check engine light. piece of shit!
     
  11. 94gtstang50

    94gtstang50 Well-Known Member

    Messages:
    2,044
    Likes Received:
    0
    Joined:
    Feb 21, 2006
    just go to advance auto already and scan that bitch, its free, fast, and you find out whats wrong right away.