clatter,clatter

potty

New Member
Joined
Sep 22, 2013
Messages
3
Reaction score
0
Location
Michigan
Hello all,
I recently pulled my engine 94 coupe 5.0. Last year I ran stock internal with "p" heads and really no other mods motor ran great and quite. So this winter I added exp intake e cam and TFS stage one springs and all you can hear is lifters oil gauge is at better than half way on normal. Any advice please.
 

Addermk2

Well-Known Member
Joined
Mar 7, 2006
Messages
2,505
Reaction score
33
Did you replace your lifters?
Did you soak them in oil before installing them?
Did you check for proper pushrod length?
Did you shim your rockers?
Did you verify the correct installed height of your valve springs?

I could go on... But ill let you catch up first.
 

SLOW95GTS

Active Member
Joined
Feb 17, 2011
Messages
749
Reaction score
8
Roller rockers are probably hitting the valve covers...
 

99GreenStang

Active Member
Joined
Jan 18, 2013
Messages
726
Reaction score
14
i agree with addermk2 if you changed heads you need to measure rod length .
 

G_94_T

Member
Joined
Oct 1, 2006
Messages
217
Reaction score
5
Location
TN
I don't see where he changed his heads. Intake, cam, valvesprings......
 

Addermk2

Well-Known Member
Joined
Mar 7, 2006
Messages
2,505
Reaction score
33
I don't see where he changed his heads. Intake, cam, valvesprings......

Hello all,
I recently pulled my engine 94 coupe 5.0. Last year I ran stock internal with "p" heads and really no other mods motor ran great and quite. So this winter I added exp intake e cam and TFS stage one springs and all you can hear is lifters oil gauge is at better than half way on normal. Any advice please.



It's there.
 

Forum statistics

Threads
74,489
Messages
1,447,540
Members
13,367
Latest member
DurtyRagu

Members online

Top