Cobra brake issue...(clunking sound)

Discussion in 'Suspension and Brakes' started by Above118, Apr 17, 2014.

  1. Above118

    Above118 Active Member

    Messages:
    601
    Likes Received:
    9
    Joined:
    Feb 2, 2013
    I recently did the cobra brake swap...notice i have a "clunking" sound when i tap the brakes,or going over bumps..
    Brackets are bolted down tight as can be... pads have there clips on them...the sliders are new from Advanced auto.
    I did notice the sliders fit a little loose from the E-clip on back...is that normal? Kinda sounds like the pads are shifting,but show no wear of it.

    any ideas bc im stumped and the sound makes me :mad:
     
  2. DropTopPony

    DropTopPony Administrator Staff Member Admin SN95 Supporter

    Messages:
    15,342
    Likes Received:
    119
    Joined:
    Jan 12, 2006
    Location:
    South Jersey
    You sure its the brakes?
     
  3. Above118

    Above118 Active Member

    Messages:
    601
    Likes Received:
    9
    Joined:
    Feb 2, 2013
    yea... all new bushings all the way around the front end,new ball joints, its a very pro dominant sound when i tap the brakes... and if im going over bumps that i know will make the noise i will ride the brakes for a second and it wont make any sounds.
     
  4. g36 monkey

    g36 monkey Moderator Staff SN95 Supporter

    Messages:
    14,057
    Likes Received:
    539
    Joined:
    Nov 15, 2008
    Location:
    Orlando, Fl
    I had a similar issue. You sure you have the anti-rattle clips installed correctly.

    Without them in right I would get noise over every tiny little bump, however when braking the sound went away
     
  5. Cpotts13

    Cpotts13 Well-Known Member

    Messages:
    1,594
    Likes Received:
    36
    Joined:
    Mar 11, 2012
    Location:
    Biloxi, MS
    I am 100% sure this Is his problem. I had the exact same issue when I did my cobra brake swap. It's the antirattle clips he needs.

    Sent from my SAMSUNG-SGH-I337 using Tapatalk
     
  6. g36 monkey

    g36 monkey Moderator Staff SN95 Supporter

    Messages:
    14,057
    Likes Received:
    539
    Joined:
    Nov 15, 2008
    Location:
    Orlando, Fl

    That's certainly what it sounds like to me. Honestly, the first time around I threw those clips away because I couldn't get them in right. It's actually pretty easy once you look at it for a bit though.

    I bought a new set of pads for $18 because it was cheaper than the $20 set of rattle clips, and it came with them!
     
  7. Win

    Win Legend

    Messages:
    9,514
    Likes Received:
    8
    Joined:
    Nov 20, 2006
    Location:
    Kennesaw, Ga
    The pistons slamming into the pads can be a little louder also then what your used to on the regular GT brakes.

    To me it sounds like your slide pins are worn. Causing the caliper to move around when you tap on the brakes.
     
  8. Win

    Win Legend

    Messages:
    9,514
    Likes Received:
    8
    Joined:
    Nov 20, 2006
    Location:
    Kennesaw, Ga

    If your meaning the rubber inside the indicators you can't buy them anywhere anymore.

    To me it sounds like the slide pins are worn.
     
  9. g36 monkey

    g36 monkey Moderator Staff SN95 Supporter

    Messages:
    14,057
    Likes Received:
    539
    Joined:
    Nov 15, 2008
    Location:
    Orlando, Fl
    No no [MENTION=8860]Win[/MENTION], anti rattle clips on the back of the pad. If installed incorrectly or not at all, these exact symptoms occur
     
  10. rz5.0

    rz5.0 Legend

    Messages:
    5,853
    Likes Received:
    130
    Joined:
    Mar 26, 2010
    Location:
    Great state of TEXAS
    Really mine just squeaked allot with no clips

    Enviado usando mi SHP-L710 usando TapaTalk
     
  11. Win

    Win Legend

    Messages:
    9,514
    Likes Received:
    8
    Joined:
    Nov 20, 2006
    Location:
    Kennesaw, Ga
    Indicator clips / anti rattle clips yes I know what you mean but a worn slide pin can be the exact sound also :) most people forget about those when doing the cobra brake upgrade.
     
  12. g36 monkey

    g36 monkey Moderator Staff SN95 Supporter

    Messages:
    14,057
    Likes Received:
    539
    Joined:
    Nov 15, 2008
    Location:
    Orlando, Fl
    eh, mine came with nice new ones, I knew that wasn't the issue ;p
     
  13. Win

    Win Legend

    Messages:
    9,514
    Likes Received:
    8
    Joined:
    Nov 20, 2006
    Location:
    Kennesaw, Ga

    I think I have some old ones of things. I'll get some pics so we can get his issue narrowed down.
     
  14. Above118

    Above118 Active Member

    Messages:
    601
    Likes Received:
    9
    Joined:
    Feb 2, 2013
    [MENTION=10997]g36 monkey[/MENTION] ahhh it might be the rear anti rattle clips!! i have the fronts,but im not sure i put the rears on...fml. lol....my pads only came with 2..not 4.
    [MENTION=8860]Win[/MENTION] I know for sure not the slide pins,those are brand new. i thought those would be the case 1st.
     
  15. Win

    Win Legend

    Messages:
    9,514
    Likes Received:
    8
    Joined:
    Nov 20, 2006
    Location:
    Kennesaw, Ga
    these ??


    [​IMG]
     
  16. g36 monkey

    g36 monkey Moderator Staff SN95 Supporter

    Messages:
    14,057
    Likes Received:
    539
    Joined:
    Nov 15, 2008
    Location:
    Orlando, Fl
  17. Cpotts13

    Cpotts13 Well-Known Member

    Messages:
    1,594
    Likes Received:
    36
    Joined:
    Mar 11, 2012
    Location:
    Biloxi, MS
    Yes. The absence of these was my problem..

    Sent from my SAMSUNG-SGH-I337 using Tapatalk
     
  18. Above118

    Above118 Active Member

    Messages:
    601
    Likes Received:
    9
    Joined:
    Feb 2, 2013
    Win Cpotts13 g36 monkey guess what guys,that was NOT the issue.....i have the clips in correct locations.

    wanna know the issue?.... IM A DIP SHIT!!...in my "rush" to get them on...i put the calipers/brackets on the wrong side!!

    so when i tap the brakes,the pads shift forward,and compress the clips.rather then the front of them being snug against the bracket..
    i look my wheel off and looked at and and literately said out loud.. "what dumbass put these on?!"

    lol thanks for all the replies tho guys..i appreciate it.
     
  19. Win

    Win Legend

    Messages:
    9,514
    Likes Received:
    8
    Joined:
    Nov 20, 2006
    Location:
    Kennesaw, Ga
    So you had the bleeders on the bottom?
     
  20. Cpotts13

    Cpotts13 Well-Known Member

    Messages:
    1,594
    Likes Received:
    36
    Joined:
    Mar 11, 2012
    Location:
    Biloxi, MS
    Smh.. glad you found it!

    Sent from my SAMSUNG-SGH-I337 using Tapatalk