code 543

Discussion in 'The Garage' started by SvtBlack95, Apr 4, 2007.

  1. SvtBlack95

    SvtBlack95 Well-Known Member

    Messages:
    2,594
    Likes Received:
    1
    Joined:
    Jul 27, 2006
    alright i picked up a code using my snapon scanner and it said code 543- O,C Fuel Pump circuit open; Battery to PCM ........do i need a new fuel pump???
     
  2. TxCobrA98

    TxCobrA98 Legend

    Messages:
    7,976
    Likes Received:
    3
    Joined:
    May 14, 2006
    umm iono what that stuff means but when you turn your car on to the accessory mode or w/e it is.. the one before you actually start the car, do you hear the whine noise from the fuel pump?
     
  3. SvtBlack95

    SvtBlack95 Well-Known Member

    Messages:
    2,594
    Likes Received:
    1
    Joined:
    Jul 27, 2006
    ya i hear the fuel pump its working i just dont understand the code and how to fix it cuz its making my car runn like poop..... if i hit WOT then it snaps out of it and its back to normal.... i slow down and its back to stuttering again
     
  4. Downshift

    Downshift Well-Known Member

    Messages:
    1,957
    Likes Received:
    0
    Joined:
    Jan 21, 2006
    How new is that 255? Or is it not in yet?
    Something definetly sounds fishy though man, you said when you WOT its fine but otherwise no.... Did you just get it tuned?
     
  5. SvtBlack95

    SvtBlack95 Well-Known Member

    Messages:
    2,594
    Likes Received:
    1
    Joined:
    Jul 27, 2006
    i didnt put the new 255 hp fuel pump in its still the old one .....i mean if its a bad fuel pump then that sno problem i have one sitting right here but Fuel Pump circuit open; Battery to PCM seems wierd to me
     
  6. 94Vert

    94Vert Active Member

    Messages:
    878
    Likes Received:
    0
    Joined:
    Jan 4, 2007
    Do you know what the pcm is?
     
  7. SvtBlack95

    SvtBlack95 Well-Known Member

    Messages:
    2,594
    Likes Received:
    1
    Joined:
    Jul 27, 2006
    powertrain control module i think?
     
  8. 94Vert

    94Vert Active Member

    Messages:
    878
    Likes Received:
    0
    Joined:
    Jan 4, 2007
    I wouldn't put all my money on the fuel pump, but since you have one I would change it and see if it solves it.
     
  9. ripper

    ripper Well-Known Member

    Messages:
    3,323
    Likes Received:
    0
    Joined:
    Jan 2, 2007
    You have that blower on there with just a stock fuel pump?
     
  10. SvtBlack95

    SvtBlack95 Well-Known Member

    Messages:
    2,594
    Likes Received:
    1
    Joined:
    Jul 27, 2006
    ya i have a stock fuel with the t rex inline ran awesome never leaned out on the dyno ...... i bought a 255 hp thats goin in it soon just wasting some more gas so i wont have to siphon alot of fuel alot...... but it shouldnt give me a code right unless the fuel pump it self is lefting go
     
  11. SvtBlack95

    SvtBlack95 Well-Known Member

    Messages:
    2,594
    Likes Received:
    1
    Joined:
    Jul 27, 2006
    codes 172 o2 sensor lean bank 1 and 332 egr valve not opening also came it does anyone think those may have caused this??
     
  12. ripper

    ripper Well-Known Member

    Messages:
    3,323
    Likes Received:
    0
    Joined:
    Jan 2, 2007
    Lean means your fuel pump is going or cant keep up with fuel demand. Ive got a 96 so im sure what the codes mean though.
     
  13. SvtBlack95

    SvtBlack95 Well-Known Member

    Messages:
    2,594
    Likes Received:
    1
    Joined:
    Jul 27, 2006
    i just bought an o2 sensor ill putt it on tommorrow and see how she runs
     
  14. Hybridbird

    Hybridbird Active Member

    Messages:
    545
    Likes Received:
    0
    Joined:
    Dec 31, 2006
    The PCM is keeping your fuel pump circuit open all the time,its not getting enough/intermittent power.You don't have this problem under WOT because your PCM goes into closed loop mode and doesn't take and input from any sensors,it just maxes out on everything.
     
  15. ripper

    ripper Well-Known Member

    Messages:
    3,323
    Likes Received:
    0
    Joined:
    Jan 2, 2007
    There ya go i knew someone would know what the hell was goin on. I asked my mech and he said the exact thing hybrid.
     
  16. SvtBlack95

    SvtBlack95 Well-Known Member

    Messages:
    2,594
    Likes Received:
    1
    Joined:
    Jul 27, 2006
    ok now that i know whats goin on how do i fix this problem???
     
  17. SvtBlack95

    SvtBlack95 Well-Known Member

    Messages:
    2,594
    Likes Received:
    1
    Joined:
    Jul 27, 2006
    anyone??????
     
  18. 94Vert

    94Vert Active Member

    Messages:
    878
    Likes Received:
    0
    Joined:
    Jan 4, 2007
    Try changing the o2 sensor. I would change the pump anyway though. Your making high hp and the stock pump is only gonna last so long.
     
  19. SvtBlack95

    SvtBlack95 Well-Known Member

    Messages:
    2,594
    Likes Received:
    1
    Joined:
    Jul 27, 2006
    ya im gonna start today on the pump and o2 sensor ...... now i have a stock fuel regulator will it effect the way the new pump flows ?? i know i need to get one its just i dnt have cash right now
     
  20. 94Vert

    94Vert Active Member

    Messages:
    878
    Likes Received:
    0
    Joined:
    Jan 4, 2007
    I would think the stock preasure would be ok. Especially since your new pump can push 255 lph out.