Corrosion on Positive battery terminal

Daryl

Well-Known Member
Joined
Apr 5, 2020
Messages
1,300
Reaction score
571
Location
SoCal
$135 for the battery (will be there by 1:00) and $30 for a pair of wiper blades.
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
28,004
Reaction score
3,751
Location
Evansville Indiana
I had never heard of the overcharging thing but after looking it up I did find some info that said it could be the problem. Any idea what voltage your seeing and I mean a number not the location on the stock gauge.
 

Daryl

Well-Known Member
Joined
Apr 5, 2020
Messages
1,300
Reaction score
571
Location
SoCal
Put in a Motorcraft battery today (along with new MotorCraft wiper blades). Hope this cures the problem…
D246C6BA-9433-4856-B21F-C42E9DEEBD9F.jpegEA3D1688-6268-4916-B2AF-1E52513B90E3.jpeg
 

BOS-94-003

Active Member
Joined
Apr 25, 2007
Messages
655
Reaction score
4
Why not head to Ford and by a battery at the dealer. Just bought the top of the range Motorcraft at Simi Ford for 167.00 for the Explorer. The Motorcraft battery in the black car is 7 years old and still working.

Jake
Just paid 176 for a duralast gold at autozone for my 17 explorer sport. Terminal was so corroded that it broke off trying to remove the clamp. Would of preferred a motor craft but it was a 8pm repair that came out of no where and I needed it running for work in the morning. I did get the little felt pad kit and installed it so we will see.
 

Latest posts

Forum statistics

Threads
75,024
Messages
1,454,617
Members
13,638
Latest member
HybridLogan

Members online

Top