could this be causing my car to run hot?

Discussion in '96-04 - 2V Specific' started by MoonlightGT, May 25, 2007.

  1. MoonlightGT

    MoonlightGT Member

    Messages:
    116
    Likes Received:
    0
    Joined:
    Oct 18, 2006
    Location:
    Windsor Ontario Canada
    im missing the plastic air deflector at the bottom of the front bumper right under the rad. could this be causing my car to run hot? the old one was all fucked up so i took it off but i never thought it did to much. should i get another one??
     
  2. warpspeed1414

    warpspeed1414 New Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    May 17, 2007
    Yes it could cause your vehicle to run hot. I would get a new one a put it on.
     
  3. DropTopPony

    DropTopPony Administrator Staff Member Admin SN95 Supporter

    Messages:
    15,342
    Likes Received:
    119
    Joined:
    Jan 12, 2006
    Location:
    South Jersey
    It might be aiding to your cooling issues, that dam does direct air up into the engine are for cooling.
     
  4. DropTopPony

    DropTopPony Administrator Staff Member Admin SN95 Supporter

    Messages:
    15,342
    Likes Received:
    119
    Joined:
    Jan 12, 2006
    Location:
    South Jersey
    And 96's do have a weak cooling system that was upgraded in 97.
     
  5. 96 blue moon

    96 blue moon Active Member

    Messages:
    288
    Likes Received:
    0
    Joined:
    May 7, 2007
    I also have a 96 GT and I had to take mine off some time ago. I don't have any over heating issues. I like your car dude. it looks just like mine. Nice color and rims!!!!
     
  6. MoonlightGT

    MoonlightGT Member

    Messages:
    116
    Likes Received:
    0
    Joined:
    Oct 18, 2006
    Location:
    Windsor Ontario Canada
    thanks bro. i love the moonlight blue , its the best!
     
  7. scarface

    scarface Guest

    Iwouldnt think that would be the cause...it helps with the airflow, but not enough to make you over heat if it isnt there. I think you may have other issues.
     
  8. 96 blue moon

    96 blue moon Active Member

    Messages:
    288
    Likes Received:
    0
    Joined:
    May 7, 2007
    I agree with scarface about your overheating issues. My lower air deflector has been off for a couple of years now and I don't have a overheating problem. I think you have a problem somewhere else. Is your electric fans working properly? Man, your car looks just like mine. The same color and rims. Looks great dude.
     
  9. DFG_magic

    DFG_magic Well-Known Member

    Messages:
    2,065
    Likes Received:
    6
    Joined:
    Nov 29, 2007
    Location:
    Kennesaw, GA
    I have no deflector on my 96 Saleen. No cooling issues here. BTW, Moonlight Blue FTMFW!!! :new_year:
     
  10. vermilion

    vermilion Legend

    Messages:
    6,300
    Likes Received:
    153
    Joined:
    Sep 15, 2007
    Location:
    maryland
    id look into your thermostat. and if you have underdrive pullies that "might" be a problem. if i read right the weaker 96 was the coolant crossover in the old npi manifolds. my full recommendations are checking your anti-freeze mixture, thermostat, and all else water pump.. someone else could chime in also. those are my recommendations.
     
  11. mike97gt

    mike97gt Active Member

    Messages:
    312
    Likes Received:
    0
    Joined:
    Jun 4, 2007
    Location:
    Red Deer, Alberta, Canada
    also maybe try cleaning off the surfaces of your radiator really good.. when my car was overheating it was just the rad was getting all plugged up between the fins.
     
  12. voidfinger

    voidfinger Well-Known Member

    Messages:
    3,880
    Likes Received:
    0
    Joined:
    Dec 16, 2006
    are you guys talking about that thing that is like a scrub gaurd? could anyone take a pic of it... i don't remember seeing anything on my 98 like that...