Crap!!!!

Quick96Mystic

Active Member
Joined
Jul 20, 2006
Messages
310
Reaction score
0
I lost the assembly kit for my subframes!!!!!!! :slap:


now i cant put my damn torque arm on!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!








AHHHHHHHHHHHHHHHH!!!!!!!!!!!!!!!!!!!!!!!

AND I ORDERED THE WRONG REAR SWAYBAR FROM MM!!!!!!!!!


:slap: :slap: :slap: :slap: :slap: :slap: :slap: :slap: :slap:
 

19mustang95

Legend
Joined
Jun 25, 2006
Messages
6,137
Reaction score
2
does any of it fit a 96 GT, cause i accept donations ^-^

and are your subframes not weld-ins?
 

Quick96Mystic

Active Member
Joined
Jul 20, 2006
Messages
310
Reaction score
0
Nope, not weld-ins.. wish they were.. would've made things easier...


maybe i can have them welded on..?


haha.. i'd give them to ya man.. but.. last time i bought something for my stang was like 6 months ago.. so, my torque arm, swaybar, subframes.. all that shit has been sitting around..

tight budget = poop
 

19mustang95

Legend
Joined
Jun 25, 2006
Messages
6,137
Reaction score
2
you shoulda got weld-in ones to begin with....weld-ins>bolt-ins. :bunny3:
 

Dalamar

Post Whore
SN95 Supporter
Retired Staff
Joined
Feb 3, 2006
Messages
13,863
Reaction score
106
Location
SLC, UT
I like my weld on's and torque arm ;)
I'm sure they can send you the stuff, what parts are you missing.

For weld on there's just a few small plates that overlap the sub frame tubes and the sub frame on the car.
Call them up and I'm sure they'll get it right out to ya.

Should be sweet when she's back running down the road.
 

Forum statistics

Threads
74,876
Messages
1,452,441
Members
13,561
Latest member
ffpletch

Members online

Top