DTC's | Need direction on solution

Discussion in '96-04 - 2V Specific' started by JerZeyStangz, Oct 11, 2016.

  1. JerZeyStangz

    JerZeyStangz Well-Known Member

    Messages:
    3,614
    Likes Received:
    39
    Joined:
    Jan 13, 2006
    Location:
    Northern NJ
    What's up guys,

    My has stang been acting up for last month or two! Its funny when your weekend ride becomes your daily for a little while and you start getting little issues with it, oh the joy!!! Moving on...these DTC's I am not familiar with because I haven't really encountered a problem like this before. When the car is in closed loop, on certain mornings it will have a rough idle to shake the car then go away. Sometimes it doesn't happen at all and sometimes it does. I really feel it when the car is accelerating in its OD gear at about 1500 rpms. You do not feel it when your on the gas but if I were to get on the gas in any gear between 1500-2000 rpm, you feel the car lose a bit of power sometimes. Here are DTC's below:

    P0131 - Oxygen Sensor Circuit Low, Voltage Bank 1 Sensor 1
    P0155 - Oxygen Sensor Heater Circuit, Bank 2 Sensor 1
    P1131 - Lack of HO2S11 Switch - Sensor Indicates Lean
    P1151 - Lack of HO2S11 Switch - Sensor Indicates Lean

    Do you think my O2 sensors are going out? My gut feeling is that there is another issue at hand. I believe there could be minor vacuum leaks around the engine and I need to dig in. I have Bosch sensors if anyone wants to know the brand and they been on the car for almost 30-40k.
     
  2. DropTopPony

    DropTopPony Administrator Staff Member Admin SN95 Supporter

    Messages:
    15,342
    Likes Received:
    119
    Joined:
    Jan 12, 2006
    Location:
    South Jersey
    Is the car shaking/shuddering at 1500-2000? Almost like driving over the rumble strips on the side of the road?
     
  3. 96blak54

    96blak54 Legend

    Messages:
    7,485
    Likes Received:
    804
    Joined:
    Feb 21, 2011
    Location:
    Ky
    Lol....his car has the drunk bumps!
     
  4. 07GtS197

    07GtS197 Well-Known Member

    Messages:
    1,393
    Likes Received:
    188
    Joined:
    Mar 16, 2015
    Location:
    Naples, Fl
    Sounds like a vacuum leak. By the way op bosch o2 sensors are trash. I had one on my 07 gt and it lasted all of 10k miles if that.
     
  5. Nighttrain

    Nighttrain Well-Known Member

    Messages:
    1,429
    Likes Received:
    5
    Joined:
    Jun 10, 2016
    Location:
    Atglen pennsylvania
    That would be the first thing i do is change O2's then start with the norm, fuel pressure, spark, vac leaks. Grab a can of starter fluid and see if you get an rpm jump while youre hunting.
     
  6. JerZeyStangz

    JerZeyStangz Well-Known Member

    Messages:
    3,614
    Likes Received:
    39
    Joined:
    Jan 13, 2006
    Location:
    Northern NJ
    Yep! This is exactly how it feels, and its random too...

    Lol! Hey I keep it sober most of the time


    Yeah im going with the genuine Ford kind next time.

    When I spray the starter fluid should I spray near vac leaks that I think is there?



    Sent from my iPhone using Tapatalk
     
  7. 07GtS197

    07GtS197 Well-Known Member

    Messages:
    1,393
    Likes Received:
    188
    Joined:
    Mar 16, 2015
    Location:
    Naples, Fl
    Ntk are oem o2 sensors but are half the cost of motorcraft parts. As far as using the starting fluid yes you spray it around the intake. Spray all the vacuum lines and around gaskets inclusing around the intake plenum and throttle body.
     
  8. DropTopPony

    DropTopPony Administrator Staff Member Admin SN95 Supporter

    Messages:
    15,342
    Likes Received:
    119
    Joined:
    Jan 12, 2006
    Location:
    South Jersey
    Nate, when is the last time you flushed the trans fluid? If your car is shuddering the way I described then it sounds like torque converter shudder. It happened to mine and is very common with the 4R70W.
     
  9. 07GtS197

    07GtS197 Well-Known Member

    Messages:
    1,393
    Likes Received:
    188
    Joined:
    Mar 16, 2015
    Location:
    Naples, Fl
    To add to above,

    like said its a common problem with the 4r70w and in 98 ford changed their recommended trans fluid from mercon to mercon v. This was fords "fix" for torque converter shutter among other things.
     
  10. JerZeyStangz

    JerZeyStangz Well-Known Member

    Messages:
    3,614
    Likes Received:
    39
    Joined:
    Jan 13, 2006
    Location:
    Northern NJ
    I do have brand new fluid in my garage and I'm a little over do for the change. I have a few questions, can you get shudder when the car is stone cold? And how does that relate to the DTC's? Now I want to change fluid even more now lol.

    Interesting information. I have amsoil OE fluid that exceeds mervon V specs and can't wait to try it out. It's a dark red/light brown so it's do for replacing anyway



    Sent from my iPhone using Tapatalk
     
  11. DropTopPony

    DropTopPony Administrator Staff Member Admin SN95 Supporter

    Messages:
    15,342
    Likes Received:
    119
    Joined:
    Jan 12, 2006
    Location:
    South Jersey
    I would get tc shudder at random times but mostly under light load at lower rpm's. I just let up on the accelerator and it would stop. It got progressively worse until I changed to Mercon V.
     
  12. JerZeyStangz

    JerZeyStangz Well-Known Member

    Messages:
    3,614
    Likes Received:
    39
    Joined:
    Jan 13, 2006
    Location:
    Northern NJ
    I did get this shudder when it was 90+ degrees out in July. I remember going to the gym and pulling in the parking lot and felt my car shaking at 600rpms+/- under foot brake load. I haven't really experienced this issue in cooler weather but the fluid is 10k over due.