ecu

Discussion in '94-95 5.0 - Specific' started by 1slow50, Jun 14, 2014.

  1. 1slow50

    1slow50 New Member

    Messages:
    69
    Likes Received:
    0
    Joined:
    Nov 10, 2013
    Location:
    Glen Burnie
    is there a way I can test the ecu to see if its still or bad???? or do I need to find a good ecu n put it in.
     
  2. toyman

    toyman Active Member

    Messages:
    874
    Likes Received:
    9
    Joined:
    Aug 25, 2008
  3. 1slow50

    1slow50 New Member

    Messages:
    69
    Likes Received:
    0
    Joined:
    Nov 10, 2013
    Location:
    Glen Burnie
    Yea 998, 157, keep alive memory fail code.

    Sent from my PC36100 using Tapatalk 2
     
  4. 94mustangsvt

    94mustangsvt New Member

    Messages:
    45
    Likes Received:
    0
    Joined:
    May 31, 2014
    Location:
    Oceanside, California
    Unless the car was in a major accident, I've almost never heard of the computer going bad on these cars. 157 is a MAF issue code. Try cleaning the MAF sensor and check to see if it has power going to it. Also, check your ground wires. To clear the other code -

    [FONT=Times New Roman, Times, serif]To clear keep alive memory, disconnect and isolate negative battery cable for a minimum of five minutes. After clearing memory, it is necessary to drive vehicle a minimum of 10 miles to allow processor time to relearn value.
    http://www.troublecodes.net/ford/[/FONT]
     
  5. Rallim

    Rallim Active Member

    Messages:
    730
    Likes Received:
    21
    Joined:
    May 5, 2011
    Location:
    Bellingham, WA
    I had the memory fail code as well, but I'd disconnect the battery because I had a short somewhere so it had a drain, pretty sure that's where I got mine.