Finally it idles correctly

Discussion in '96-04 - 2V Specific' started by cokerchuck, Aug 27, 2014.

  1. cokerchuck

    cokerchuck New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Nov 11, 2012
    Location:
    Southeast Texas
    04 GT vert would idle too low and die on occassion. I replaced the IAC with a unit from O'Reilly and the idling improved but would hang way too high even while stopped at an intersection. Mechanic buddy o'mine said Ford only for certain parts including the IAC. I put the Motocraft on there and BAM she runs great and idles correctly. I've been dealing with this for 2 months trying to figure out what else could be the problem. Ol'buddy said to only use FoMoCo for O2 sensors as well, but I'll wait a bit to change those.
     
  2. Mustanger

    Mustanger Well-Known Member

    Messages:
    2,310
    Likes Received:
    115
    Joined:
    Dec 3, 2006
    Location:
    Southern Oregon
    And only OEM Ford clutch cables...get ones from MM as they only sell Ford cables but modify them to fit firewall adjusters if that is what you run.
     
  3. Ferocious

    Ferocious Legend SN95 Supporter

    Messages:
    12,255
    Likes Received:
    592
    Joined:
    Jun 1, 2011
    Location:
    San Diego
    I've been through so many IACs it's not even funny.
     
  4. 96blak54

    96blak54 Legend

    Messages:
    7,468
    Likes Received:
    778
    Joined:
    Feb 21, 2011
    Location:
    Ky
    I will confirm the o2 sensors! Im glad you posted this tech! Dood...thank you!!