front speakers are dead

Discussion in 'Electrical & Stereo' started by bigjohnson4.6gt, Jun 2, 2007.

  1. bigjohnson4.6gt

    bigjohnson4.6gt Well-Known Member

    Messages:
    3,322
    Likes Received:
    0
    Joined:
    Dec 23, 2006
    about 4 months ago i bought some 6x9 kicker 2 way door speakers (2 in the front, 2 in the rear), about 2 days ago they arent working at all. I took my deck out, and just figured it was my connections in the back (all connections were electrical tapes), so i got some connectors and connected every single one, and they still dont work. I highly doubt that its the connector adapters from the factory wires to the speakers. Anyone have anything to help me out here?
     
  2. 9psi 98

    9psi 98 Active Member

    Messages:
    701
    Likes Received:
    0
    Joined:
    May 3, 2007
    I'd take the speakers out and try them on anything just to see if the work. Then i'd get a meter (a cheap one will work) and do an ohm resistance check on your wires to rule out and connection/breakage problems. If everything checks out, you may have burned out a channel in your deck. Check it with another speaker. Hope that helps.
     
  3. 96 blue moon

    96 blue moon Active Member

    Messages:
    288
    Likes Received:
    0
    Joined:
    May 7, 2007
    Like 9psi 98 said just take your dvom meter and select the ohms position, Then take the black lead wire from your dvom and install it on one end of the speaker wire ( behind your radio ) then take the red lead wire from your dvom and install it on the other end of the same wire that you installed the black lead to and then read the ohms on the meter. If the wire is good the meter would read 0.00. Do this for each wire that controls the front speakers. O0 Did you use butt connectors when you repaired the connections behind the radio?
     
  4. bigjohnson4.6gt

    bigjohnson4.6gt Well-Known Member

    Messages:
    3,322
    Likes Received:
    0
    Joined:
    Dec 23, 2006
    thanks guys, i forgot to put a post up saying that i fixed the problem, it was weird cause one of the 2 wires connecting from each of the 2 front speakers disconnected, so i reconnected and taped them up and its good
     
  5. 96 blue moon

    96 blue moon Active Member

    Messages:
    288
    Likes Received:
    0
    Joined:
    May 7, 2007
    Glad you found the easy fix on your speakers. :thumb:
     
  6. 9psi 98

    9psi 98 Active Member

    Messages:
    701
    Likes Received:
    0
    Joined:
    May 3, 2007
    If it isn't one thing it's always another...... :comando:
     
  7. bigjohnson4.6gt

    bigjohnson4.6gt Well-Known Member

    Messages:
    3,322
    Likes Received:
    0
    Joined:
    Dec 23, 2006
    i live by that slogan