got my jlt today...

97vertstang

Well-Known Member
Joined
Jan 11, 2006
Messages
2,879
Reaction score
1
well i got my jlt and its huge!!! heres some pics.....
jlt012.jpg

jlt011.jpg

jlt010.jpg

im having a couple of little problems though, since i got the stock throttle body , i need a spacer and the stock 90 degree rubber doesnt clamp it perfect. 2nd since the maf is not hold on anymore it seems to wobbloly for my taste.3rd , at first it had a shittle idle after a while it got better than i went for a cruise and at full WOT it gets a CEL. im hoping its not going lean or something???? :dunno: i clamped it very hard and now im a get a bigger throttle body so i dont have to use that rubber spacer, and a FPR so i can higher the fuel pressure just to make sure its not running lean. it looks very good and it definitely sucks :chef3:
 

Suspect

Well-Known Member
Joined
Jan 13, 2006
Messages
2,776
Reaction score
1
Location
ATL
what does the butt dyno say? i was actually wanting to swap mine for one of those sometime later.
 

97vertstang

Well-Known Member
Joined
Jan 11, 2006
Messages
2,879
Reaction score
1
i felt some low end torque loss, it wont burn em like it used to, but it revs a lot easier and my 3rd gear pull very nice compared to before. i think the low end torque loss was due to some air velocity loss. once i get a intake manifold and throttle body it should work way better. u can hear it suck lots more air than before. i wouldnt bother with any other cai/rai other than jlt and demolet.
 
S

scarface

Guest
honestly the couplers look like they came from lowes, and the pipe is just a 4 inch piece of pipe...whats the big deal?

Please school me.
 

97vertstang

Well-Known Member
Joined
Jan 11, 2006
Messages
2,879
Reaction score
1
scarface said:
honestly the couplers look like they came from lowes, and the pipe is just a 4 inch piece of pipe...whats the big deal?

Please school me.
actually thats pretty much all it is , and a cool sticker ;D, i dont know how to make one.


i have a problem the shitty idle came back today when i started her up. the car idles like shit and it works fine when ur already driving. i rotated the maf like this
jlt013.jpg

and it seems a little smoother but still idles rougher than before, i disconnected the battery for 30min. and it idled very rough at the beginning and than it calm but still kinda rough for my taste. what should i do??? does the computer just needs to get used to the new airflow or is it something wrong????
 

97vertstang

Well-Known Member
Joined
Jan 11, 2006
Messages
2,879
Reaction score
1
what do u guys think of this heat shield
http://demolet.com/
just go to new products
its nice , its $75 by itself, i called and asked i think ima order it and see if it helps and so i dont get none of that hot air.
 

Red96GT

Legend
Joined
Sep 23, 2006
Messages
5,374
Reaction score
0
5.HOE said:
Red96GT said:
94pacecar435 said:
looks ugly :hammer:
I can't tell if you were joking but I think it looks good. O0
yeah hes a friend, he just likes to screw around with my shit

lol, ok, at first I thought he was just being a d-bag. Anyways, carry on 94pacecar O0
 

Latest posts

Forum statistics

Threads
74,902
Messages
1,452,815
Members
13,578
Latest member
derekcdrake88

Members online

Top