HCI swap weak, hesitates and stumbles under hard accleration

Kylebach14

New Member
Joined
Mar 26, 2014
Messages
82
Reaction score
0
Just did a HCI swap and when I mash it, it stumbles, hesistates and doesn;t have any balls until around 3000 then it throws you in the back of your seat. It cant even break them lose when it's wet. Any ideas what this could possibly be? Vacuum leak?

94 5.0
TFS 1 cam
1.6 roller rockers
6.500 pushrods
Vic Jr. Heads
Typhoon U/L intake
Walbro 255 fuel pump
Stock injectors, MAF, TB
AODE with shift kit
 

SLOW95GTS

Active Member
Joined
Feb 17, 2011
Messages
749
Reaction score
8
You put victor jr.'s on a 302? wow. first you'll need atleast 24lb. injectors, with a MAF calibrated for the injectors, a 255lph fuel pump, and most likely a tune, unfortunately. Is the motor stroked or piston change for that 2.05 intake valve?
 

rz5.0

Legend
Joined
Mar 26, 2010
Messages
5,853
Reaction score
130
Location
Great state of TEXAS
Those head are huge. You are not going to get anything on the low end. . Also did you measure you ptv.. bet you prob touching your piston. I did with same cam and afrs. Not enough to bend but you could see the marks on the pistons..

Enviado usando mi SHP-L710 usando TapaTalk
 

tykempster

Member
Joined
Feb 25, 2014
Messages
103
Reaction score
0
Did you check the plugs and wires at night with no lights and make sure they aren't arcing anywhere? i've had a plug wire burn and a plug crack since my HCI, both were annoying and took 5 minutes to fix
 

RichV

Well-Known Member
Joined
May 6, 2012
Messages
4,230
Reaction score
248
Location
CO
Definitely check for a vac leak. Any codes? GT ECU/injectors?
 

Musturd

Legend
Joined
Feb 12, 2011
Messages
9,148
Reaction score
651
Those heads are huge for a 302 I've only really seen them work we'll on boosted 302's and it's still chancey
 

Latest posts

Forum statistics

Threads
75,134
Messages
1,456,325
Members
13,689
Latest member
five.oh_lover

Members online

Top