help with surging and stalling

Overboost

Member
Joined
Jul 29, 2019
Messages
110
Reaction score
73
Location
Flushing, Michigan
ok, its getting annoying...
car runs and drives great... sometimes, when you come to slow down, I push the clutch and it stalls almost instantly. most of the time, when I come to stop, I push the clutch and it idles down to about 1200 and surges between 1000-1200 and when I stop, it idles down to 800 perfect, no surge or stall...

other times when I back up, and bump the gas just to roll a bit when I hit the clutch, it dies slow... always starts back up and dont do it if I dont hit clutch, only when I disengage it.

I have already cleaned the IAC and replaced it... works for about 2 hours and right back to it, exact same issue with 2 diff IAC.
I dont have a MAF that I can find. car has been tuned at livernois and I dont see a harness for a MAF so I dont think it was converted to SD

car is 98 DOHC with procharger...
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
27,926
Reaction score
3,727
Location
Evansville Indiana
is the harness on the IAC and the clips to hold it place in good shape? When the motor is cold as well as hot does it move/wiggle at all?
 

JoeR40065

New Member
Joined
Jan 31, 2021
Messages
25
Reaction score
0
ok, its getting annoying...
car runs and drives great... sometimes, when you come to slow down, I push the clutch and it stalls almost instantly. most of the time, when I come to stop, I push the clutch and it idles down to about 1200 and surges between 1000-1200 and when I stop, it idles down to 800 perfect, no surge or stall...

other times when I back up, and bump the gas just to roll a bit when I hit the clutch, it dies slow... always starts back up and dont do it if I dont hit clutch, only when I disengage it.

I have already cleaned the IAC and replaced it... works for about 2 hours and right back to it, exact same issue with 2 diff IAC.
I dont have a MAF that I can find. car has been tuned at livernois and I dont see a harness for a MAF so I dont think it was converted to SD

car is 98 DOHC with procharger...


I know that I'm not boosted or anyting but I am or I did just go through the exact same issue come to find out my vacuum line to iac valve tied iinto both pcv valves?? However there was a small leak that was happening when I was coming like to stop and I was searching between 750 to 1200 RPM and would die almost instantly and the coupling had failed where the line goes in at. Not enough to make high idle but enough for some reason to want to kill the car coming to stop only mods are bbk plenum, 75 mm tb by bbk , bbk long tubes, 21 lb injectors , Crower stage 2 cams , Cai and sct x4 tuner
 

Overboost

Member
Joined
Jul 29, 2019
Messages
110
Reaction score
73
Location
Flushing, Michigan
I know that I'm not boosted or anyting but I am or I did just go through the exact same issue come to find out my vacuum line to iac valve tied iinto both pcv valves?? However there was a small leak that was happening when I was coming like to stop and I was searching between 750 to 1200 RPM and would die almost instantly and the coupling had failed where the line goes in at. Not enough to make high idle but enough for some reason to want to kill the car coming to stop only mods are bbk plenum, 75 mm tb by bbk , bbk long tubes, 21 lb injectors , Crower stage 2 cams , Cai and sct x4 tuner

well, I could not find any lines that were bad, so I replaced one that looked questionable just below the throttle body....
it seems to have helped. it does not surge nearly as bad and it dont stall nearly as much...
hope that was it... seems to be doing good so far
 

Latest posts

Forum statistics

Threads
74,993
Messages
1,454,234
Members
13,628
Latest member
reedj304

Members online

No members online now.
Top