HELP!!!?!?!

Discussion in '96-04 - 2V Specific' started by blownstanger, Aug 6, 2007.

  1. blownstanger

    blownstanger New Member

    Messages:
    69
    Likes Received:
    0
    Joined:
    Oct 14, 2006
    Okay, I've had this problem for a while. Whenever I drive normally everything in my car is fine. But when I race I leak out coolant from my resovour. Why? I've replaced the cap b4. Nothing changed. HELP!!!!!??? :dunno:
     
  2. Late4Work

    Late4Work Well-Known Member

    Messages:
    1,430
    Likes Received:
    3
    Joined:
    Jul 25, 2007
    Could be the seal........but when u push ur engine harder it will put strain on it
     
  3. Boomer!

    Boomer! New Member

    Messages:
    74
    Likes Received:
    0
    Joined:
    Jul 11, 2007
    Hmmmmm, sounds like combustion bubbles... might want to check it out, you may have lifted a head gasket causing cylinder pressures thru the coolant system. :)
     
  4. quickstang_1994

    quickstang_1994 Well-Known Member

    Messages:
    2,208
    Likes Received:
    12
    Joined:
    Apr 30, 2006
    Location:
    Cross Anchor, SC
    I had the same problem and removed my thermostat because the motor starts to evaperate the water causing to much pressure. or it could be the head gasket under high boost.
     
  5. 9psi 98

    9psi 98 Active Member

    Messages:
    701
    Likes Received:
    0
    Joined:
    May 3, 2007
    You removed your thermostat?!? :dunno:
     
  6. quickstang_1994

    quickstang_1994 Well-Known Member

    Messages:
    2,208
    Likes Received:
    12
    Joined:
    Apr 30, 2006
    Location:
    Cross Anchor, SC
    yep it works perfect