Hiccup help

Discussion in 'The Safe Zone' started by silverskoundrel, Apr 16, 2014.

  1. silverskoundrel

    silverskoundrel New Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Mar 27, 2014
    I think the cars done it since I got it. seems like between 50-60 does it a lot.
    its abnormal. not like im just letting the rpms get too low (seems to do it even at high 2k rpms) like its losing power but I compress the clutch & rev it or downshift & im usually fine. car has a bama tune (hiccuped before tune) & 4 of the 6 "cats" or w'e theyre considered (there where 6 larger cylinder cat like objects on it lol) have been removed.
    still the issue consists after I had bama shut off the rear 02 sensors & I replaced the front two 02 sensors.
    I just changed the spark plugs, wires, & ignition coils before the tune.
    my next guess is maybe MAF or vacuum? just curious if there any suggestions before I attempt to throw money that I don't have at it lol
     
  2. silverskoundrel

    silverskoundrel New Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Mar 27, 2014
    My bad 98 4.6
     
  3. RichV

    RichV Well-Known Member

    Messages:
    4,227
    Likes Received:
    247
    Joined:
    May 6, 2012
    Location:
    CO
    Does it pull any codes?

    My 05 has a little misfire at higher RPM. Codes telling me #5cyl misfire.
     
  4. silverskoundrel

    silverskoundrel New Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Mar 27, 2014
    Yea let me go pull them real quick
     
  5. silverskoundrel

    silverskoundrel New Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Mar 27, 2014
    Ok keep in mind car used to be automatic.
    P0750
    P0755
    P0720
    P0708
    P0743
    P0354
    P0713
    P1000
    P1746
    P1900
    P1702
     
  6. silverskoundrel

    silverskoundrel New Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Mar 27, 2014
    I believe I found a bad "new coil"


    Sent from Narnia
     
  7. B.mad

    B.mad Well-Known Member Preferred Vendor

    Messages:
    1,996
    Likes Received:
    4
    Joined:
    Mar 9, 2014
    Location:
    SoCal
  8. RichV

    RichV Well-Known Member

    Messages:
    4,227
    Likes Received:
    247
    Joined:
    May 6, 2012
    Location:
    CO
    Mine ended up being plugs, which I suspected. Replaced them all with Autolite HT1 and it runs smooth as silk.