HIDs vs ABS Light

MissFivePointSlow

New Member
Joined
Oct 6, 2010
Messages
94
Reaction score
0
Location
Horsham, PA
I have HID's in my headlights and fog lights. The headlights on and off absolutely fine Fog lights as soon as they go on the ABS 9/10 times will pop on as well. This happened with our Black cobra as well. Anyone else have this issue, Resolution? Heard of it? or do I just lovely luck. Lol It doesn't seem to affect anything other then an annoying light on the dash. The HID's on the black cobra were done by Alex and The HID's on the PG Cobra were wired by the previous owner, so it's not just us somehow mixing wires and doing it the same on both cars. Even though everything is plug in play. Just putting it out there as an factor.
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
26,925
Reaction score
3,286
Location
Evansville Indiana
did you plug directly into the stock headlight wiring or use a relay to power it seperatly? I am guessing you plugged it straight in? When the HID ballast starts off it draws 10-12 amps of current till it warms up and then quickly falls to 6-8 amps and that change in current can confuse the computer to think there is a bad sensor since they are on the same circuit some where.

that is one theory anyway the other is that if you mount the ballast too close that the RF generated by the ballast causes the sensor problems.... You can try moving the ballasts if you want.

Been running HIDS on my car now for years and never had a light come on once but I did use relays.
 

1997GT4.6

Well-Known Member
Joined
Oct 10, 2010
Messages
1,992
Reaction score
69
I have the ABS light on as well but only when I turn the fog lights on with HIDs. That light is so annoying! Same problem on the GT I used to have. I would like to know the cause or a fix as well.
I'm not running the relays so that could be the fix as Scott has done.
 

OnyxCobra

Post Whore
Joined
Apr 8, 2006
Messages
14,794
Reaction score
233
Location
Rochester, NY
I had this problem with my cobra's fogs, 10/10 times turning on the HIDs would trip the ABS light. I installed a relay for the fog light HIDs and my ABS light has not come on a single time since then. I did not move any ballasts or wiring, just added a relay so the HIDs get their power from the battery instead of the stock fog light wiring. good luck.


edit: yes if you turn the HIDs on before starting the car the ABS light should remain off. it's only triggered when turning the HIDs on when the car is already running.
 

MissFivePointSlow

New Member
Joined
Oct 6, 2010
Messages
94
Reaction score
0
Location
Horsham, PA
No relays here, yeah if I pop on the HIDs while the car is running it triggers it. If the cars off and i turn them on before then start it won't come on. It's like a damn game so I don't have them on. I need to replace the fogs anyway so I will try the relay. I'm going the change over the fogs to the envoy housings.

Thank you so so much for the info! This is definitely being added as soon as it isn't sub arctic weather outside!
 

1997GT4.6

Well-Known Member
Joined
Oct 10, 2010
Messages
1,992
Reaction score
69
Sweet thanks for making this thread and thanks for relay info to Scott and Onyx! I also had no idea about turning the lights on before turning on the car would negate the abs light.
 

Forum statistics

Threads
74,489
Messages
1,447,540
Members
13,367
Latest member
DurtyRagu

Members online

Top