I have a huge problem, I just saw!!!

Discussion in '94-95 5.0 - Specific' started by eliyarbrough, Jun 1, 2007.

  1. eliyarbrough

    eliyarbrough Legend

    Messages:
    7,848
    Likes Received:
    0
    Joined:
    Jan 30, 2007
    Location:
    Nocona, TX
    I mentioned on another thread how my button on my shifter only presses when I barely apply the brake. I was just backing in for the night and saw a huge problem!! My brake lights only light up when I barely hit the pedal! If I mash the pedal, nothing happens. It was getting dark so I had my parking lights on to put my top up and stuff. I saw in my reflection on the screen door that just my normal lights lit up. I played around with it and got my lights on when I barely applied any brake! Does anyone know of why this happened? It is going in the shop 1st thing tomorrow!!! Do you have anything I can relay to my mechanic? Thanks in advance!!!
     
  2. eliyarbrough

    eliyarbrough Legend

    Messages:
    7,848
    Likes Received:
    0
    Joined:
    Jan 30, 2007
    Location:
    Nocona, TX
    I just remembered something. He said there was some sort of switch that said the brake was pressed. That way the button would release to shift gears. Could it be that whatever needs to be replaced? I can barely remember what my last meal was though!! This is a long shot.
     
  3. RACEME

    RACEME New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Apr 13, 2007
    Sounds like you have a bad switch on the brake pedal. There is a rectangle shaped switch attached on your brake pedal right where the master cyl arm attaches. It will be held on by some type of clip. You can take it off and work it with your fingers to see if that is the problem. They are cheap to replace and easy to do.
     
  4. eliyarbrough

    eliyarbrough Legend

    Messages:
    7,848
    Likes Received:
    0
    Joined:
    Jan 30, 2007
    Location:
    Nocona, TX
    Thanks! He thinks replacing that bad switch might help with my shifter problem, too. See ya!!
     
  5. eliyarbrough

    eliyarbrough Legend

    Messages:
    7,848
    Likes Received:
    0
    Joined:
    Jan 30, 2007
    Location:
    Nocona, TX
    Problem fixed!!
    The switch on the pedal's wires was coming undone. The more I pressed the worse it came undone. Now my lights light up, and my car switches out of park easily. Thanks!!