Jan 2015 ROTM - KidK9

Discussion in 'Past ROTM Winners' started by Orange 94, Jan 11, 2015.

  1. Orange 94

    Orange 94 Moderator Staff SN95 Supporter

    Messages:
    10,846
    Likes Received:
    345
    Joined:
    Oct 21, 2012
    Location:
    Alberta Canada
  2. KidK9

    KidK9 Well-Known Member

    Messages:
    1,595
    Likes Received:
    174
    Joined:
    Apr 2, 2012
    Location:
    Cincinnati, Ohio
    Thank you everyone. I appreciate it!
     
  3. 9838stang

    9838stang Well-Known Member

    Messages:
    2,494
    Likes Received:
    106
    Joined:
    Sep 13, 2010
    Location:
    Minneapolis,MN
    car looks awesome man!
     
  4. Burninriverdiver

    Burninriverdiver Well-Known Member

    Messages:
    2,341
    Likes Received:
    6
    Joined:
    Jan 1, 2014
    Location:
    Akron OH
    Congrats on the win! This is a well deserving show car
     
  5. KidK9

    KidK9 Well-Known Member

    Messages:
    1,595
    Likes Received:
    174
    Joined:
    Apr 2, 2012
    Location:
    Cincinnati, Ohio
    Thanks guys. I really appreciate it.
     
  6. Tony

    Tony Well-Known Member

    Messages:
    9,339
    Likes Received:
    913
    Joined:
    May 23, 2012
    Location:
    ohio
    car is epic kid congrats!!
     
  7. Michael Plummer

    Michael Plummer Well-Known Member

    Messages:
    413
    Likes Received:
    2
    Joined:
    Feb 20, 2007
    Location:
    Brockton, MA
    Great workmanship in this build. Congrats on being ROTM for the month of January 2015.
     
  8. Ferocious

    Ferocious Moderator Staff SN95 Supporter

    Messages:
    12,251
    Likes Received:
    583
    Joined:
    Jun 1, 2011
    Location:
    San Diego
    Congrats Kid! Fantastic work and flawless attention to detail on this car. I bet you can't wait to get it back and show it off.
     
  9. Sinned83

    Sinned83 Well-Known Member

    Messages:
    4,439
    Likes Received:
    54
    Joined:
    Feb 10, 2010
    Location:
    MA
    Such a sick car
     
  10. mcglsr2

    mcglsr2 Well-Known Member SN95 Supporter

    Messages:
    3,397
    Likes Received:
    0
    Joined:
    Jul 4, 2011
    Location:
    Orlando
    Congrats!
     
  11. KidK9

    KidK9 Well-Known Member

    Messages:
    1,595
    Likes Received:
    174
    Joined:
    Apr 2, 2012
    Location:
    Cincinnati, Ohio
    Yeah, I can't wait to get it back. It's soooo close to being done. Right now my builder is trying to iron out some electrical issues. It will start when it's cold, and it will run. But when it is shut off, it wont fire for another hour or so. Pretty strange.
     
  12. g36 monkey

    g36 monkey Moderator Staff SN95 Supporter

    Messages:
    13,826
    Likes Received:
    468
    Joined:
    Nov 15, 2008
    Location:
    Orlando, Fl
    So well deserved. Ridiculous attention to the details!
     
  13. ElrodKTPQ_89

    ElrodKTPQ_89 Well-Known Member

    Messages:
    4,962
    Likes Received:
    4
    Joined:
    Aug 6, 2013
    Location:
    Crossett, AR
    Congrats dude!
     
  14. ProKiller

    ProKiller Well-Known Member

    Messages:
    3,070
    Likes Received:
    200
    Joined:
    Jan 27, 2006
    Location:
    PA
    it's probably dumping too much fuel in on hot start. what tuning method you using?
     
  15. KidK9

    KidK9 Well-Known Member

    Messages:
    1,595
    Likes Received:
    174
    Joined:
    Apr 2, 2012
    Location:
    Cincinnati, Ohio
    To be honest, I'm not quite sure as my builder and his friend who tunes for SCT are working on it. Sorry.
     
  16. KidK9

    KidK9 Well-Known Member

    Messages:
    1,595
    Likes Received:
    174
    Joined:
    Apr 2, 2012
    Location:
    Cincinnati, Ohio
    Any reason why TMI doesn't return PMs?
     
  17. chris91

    chris91 Well-Known Member

    Messages:
    3,761
    Likes Received:
    198
    Joined:
    Apr 20, 2007
    Location:
    Cincinnati, OH
    Sounds like distributor problems. You running a MSD distributor by any chance? Seen MANY of them fail.
     
  18. cameron57

    cameron57 Well-Known Member

    Messages:
    454
    Likes Received:
    0
    Joined:
    Feb 10, 2014
    Sweet car
     
  19. KidK9

    KidK9 Well-Known Member

    Messages:
    1,595
    Likes Received:
    174
    Joined:
    Apr 2, 2012
    Location:
    Cincinnati, Ohio
    Nah the distributer has been switched out many times to confirm it's not the problem. This one is a Summit. Apparently, multiple sensors are not working and not receiving the proper voltage.
     
  20. KidK9

    KidK9 Well-Known Member

    Messages:
    1,595
    Likes Received:
    174
    Joined:
    Apr 2, 2012
    Location:
    Cincinnati, Ohio
    Well the problem has finally been solved. I'd like to thank a certain "Mustang Only" specific shop in Cincinnati for completely ****ing my wiring in order for them to make a short cut. I only had to pay a small fortune to correct their problem.