Just installed a new clutch

Madbum90

New Member
Joined
Feb 9, 2014
Messages
7
Reaction score
0
I just replaced my clutch with a spec stage 1 clutch kit. I had the flywheel resurfaced and now the transmission shakes when letting off the clutch to drive. Like clutch chatter. Everything is torqued to spec. Also it was hard to get the tranny into the bellhousing all the way there was like a inch gap and I had to tighten the 4 tranny bolts to bellhousing to get it to sit flush against the bellhousing.
 

D3VST8R96GT

Well-Known Member
Joined
Feb 19, 2009
Messages
4,007
Reaction score
90
Location
SE Georgia!
Mine chattered and then my TOB went out..... cable quadrant are things to look into as well

The D3V
 

Madbum90

New Member
Joined
Feb 9, 2014
Messages
7
Reaction score
0
Mine chattered and then my TOB went out..... cable quadrant are things to look into as well

The D3V
Ok thanks. Is it normal for the transmission to not go into the flywheel all the way until it's all bolted down?
 

Win

Legend
Joined
Nov 20, 2006
Messages
9,514
Reaction score
8
Location
Kennesaw, Ga
Were the guide pins or input shaft mared at all?

If it wasn't 100% level it can be a bear to get in there. But the shaft should slide right in and lock in.
 

G_94_T

Member
Joined
Oct 1, 2006
Messages
217
Reaction score
5
Location
TN
Installed the same clutch in my car with the same results.....chatter
 

99GreenStang

Active Member
Joined
Jan 18, 2013
Messages
726
Reaction score
14
Sounds like to me you may have forced the Trans onto the engine . The transmission should have dowels that when aligned properly sit inside the engine and then you bolt the bell housings . You shouldn't have to force the transmission into place using the bolts . Your shaft may not be fully seated causing the chatter or your flywheel bolts are loose . Have you inspected the axles ?


Sent from my iPhone using Tapatalk
 

Swapfox2145

New Member
Joined
Apr 22, 2017
Messages
27
Reaction score
0
I have been reading alot as I just went thru a nightmare having a shop replace my clutch and am now doing it myself with my refund. I have heard the spec clutches have issues and resurfacing flywheels just seems bad unless done properly. I am buying a new flywheel coupled with the mcleod clutch kit to remedy the same issue I have vibration at acceleration with a second clutch install from the shop I can't wait to go deliver them their clutch kit with my car running fine I am positive it is the flywheel and maybe you are experiencing a similar issue.
 

Forum statistics

Threads
74,489
Messages
1,447,540
Members
13,367
Latest member
DurtyRagu

Members online

Top