Looking for some help/ideas. Possibly auto trans related

CipherSpace

New Member
Joined
Jun 15, 2021
Messages
1
Reaction score
0
Location
NE Ohio, Usa
Running 95 Mustang-GT SN95. 44K miles, sat in a garage for years until about a year ago. Upgraded thermostat,coil,plug wires,coil wire,air filter,brand new fuel filter. (I have beard a humming/vibration near torque converter shifting to 3rd when I originally picked the vehicle up. It went away after transmission flush.) Vehicle gets regular oil changes. Oil pressure is around the "A" in "Normal" on the cluster, So pretty high.

So the issue is, when driving everything seems good,idles good too. After replacing fuel filter Acceleration is much better but when I pin the throttle down I have delayed reaction in actual wheel response. The rpms will jump but it's like the torque converter is lagging to catch up. I dont really feel slipping in the trans. It just seems like slow reaction to downshift / accelerate (if that makes sense) even though the throttle does react. It feels it may be torque converter related imo.

Any thoughts would be appreciated. No check engine light. Stock everything other than listed above. Car has been very well maintained. Before I replace Torque converter, TPS,CrankPS,MAF,CamPS I figured I would ask around here. THANK YOU IN ADVANCE!
 

BHernandez

New Member
Joined
Mar 7, 2022
Messages
72
Reaction score
30
Nope, nothing wrong with it. That's just how the 4R70 down shifts. Slowly. Kinda like a sloth. It'll get there when it's damn good and ready. My 98 is the same way.
 

BHernandez

New Member
Joined
Mar 7, 2022
Messages
72
Reaction score
30
If you're going on a "spirited" drive try turning off the electonic O/D. It'll will kick-down quicker.
 

Latest posts

Forum statistics

Threads
76,270
Messages
1,473,384
Members
14,154
Latest member
NekRoass

Members online

Top