Low Coolant light

Discussion in '96-04 - 2V Specific' started by jpajkos, Sep 18, 2006.

  1. jpajkos

    jpajkos Active Member

    Messages:
    622
    Likes Received:
    0
    Joined:
    Jun 20, 2006
    Whats up guys. Acouple days ago my top radiator hose went. I replaced it and filled it up with fluids. When im at idle my low coolant light stays off but when I drive it comes on. I repeatly check my fluids and it says its has a enough. I checked for some sort of bleeder valve to see if there was air in the system but couldn't find one. Is there a way to turn the light off or am I missing something? Thanks
     
  2. scarface

    scarface Guest

    clean the gunk out of the overflow tank. Mine did that when I first got it, Once I removed all the crap it stopped.
     
  3. DropTopPony

    DropTopPony Administrator Staff Member Admin SN95 Supporter

    Messages:
    15,342
    Likes Received:
    119
    Joined:
    Jan 12, 2006
    Location:
    South Jersey
    i have to keep my overflow tank almost full or my light comes on... turn your heat on and run the rpm's up to like 3k...oh take off the cap...this will get the air out of your system if you have any...hold it for a few minutes until the tstat opens and everthing is circulating.
     
  4. jpajkos

    jpajkos Active Member

    Messages:
    622
    Likes Received:
    0
    Joined:
    Jun 20, 2006
    Awesome thanks for all the help. I'll try that tonight
     
  5. Lightning Struck

    Lightning Struck Legend

    Messages:
    23,204
    Likes Received:
    2
    Joined:
    Jan 12, 2006
    my 98 did the exact same thing