Might have a wiring gremlin

Discussion in 'Electrical & Stereo' started by 07GtS197, Jan 27, 2016.

  1. 07GtS197

    07GtS197 Well-Known Member

    Messages:
    1,391
    Likes Received:
    187
    Joined:
    Mar 16, 2015
    Location:
    Naples, Fl
    So my 02 gt sits because Im not supposed to drive at the moment because of my epilepsy so I take this time to fix her up. I noticed a week ago that the negative terminal on my battery was corroding and fell apart while I tried to tighten it down. It scared the crap out of me when I was installing a new hood release cable and all of a sudden I heard a tick and my radio shut off lol. But anyway I got a new terminal and installed it yesterday but when I went to start it the battery was pretty much dead. I jumped it with my 07 gt and took it for a spin to charge the battery and it turned right back on afterwards. Ill try again on friday to see if its still dead. Now for my question, is it normal for the battery to go dead while its unplugged for a few days?

    I checked the battery with a multimeter and with the car off it reads about 12.8 volts and with it on it reads 14.5 or so. Is that normal?

    On a side note, Ive noticed the battery light will come on for a second sometimes at high rpms and come on for a while a couple weeks ago but went out after 10 or so mins.
     
  2. ttocs

    ttocs Legend

    Messages:
    25,426
    Likes Received:
    2,457
    Joined:
    Oct 9, 2009
    Location:
    Evansville Indiana
    only bad batteries will loose voltage over short periods while being unhooked. the voltages are all normal. Best way to tell is to charge it up and then disconnect it from everything and test it later to see if it looses voltage.
     
  3. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    The battery light coming on at high rpms might be an indication of the voltage regulator dying.
     
  4. GregT94SCC

    GregT94SCC New Member

    Messages:
    75
    Likes Received:
    0
    Joined:
    Jul 18, 2007
    Mine did that for years (high rpm charging light). New alternator fixed it. It was probably the regulator.
     
  5. 07GtS197

    07GtS197 Well-Known Member

    Messages:
    1,391
    Likes Received:
    187
    Joined:
    Mar 16, 2015
    Location:
    Naples, Fl
    Im sure Ill replace the alternator soon anyway. I know its a common problem on these cars. Ill disconnect the battery for a bit and report back. Its funny because itll sit for sometimes weeks at a time and the battery will be fine but then it sits for a few days with the battery unhooked and it dies lol. Do you guys think that with the battery light coming on at idle could be another indication the voltage regulator is going out?
     
  6. 07GtS197

    07GtS197 Well-Known Member

    Messages:
    1,391
    Likes Received:
    187
    Joined:
    Mar 16, 2015
    Location:
    Naples, Fl
    I noticed the other day that an interior light was on so maybe thats why its been dying. Its been turning on fine since I turned it off, though it was a little bit hard to start today. My battery light was on and would flicker with the exhaust pulses if that makes any sense. Then the fan kicked on and the battery light turned off.
     
  7. 07GtS197

    07GtS197 Well-Known Member

    Messages:
    1,391
    Likes Received:
    187
    Joined:
    Mar 16, 2015
    Location:
    Naples, Fl
    Welp after a few days of sitting the battery was completely drained, even the locks and interior wouldnt work. I replaced the battery (po didnt even put the right battery in) and it cranked right up but I noticed that the battery light stayed on. So I got my trusty volt meter and had the leads on the terminals while it was running and off. Running it was about 12.34 volts and off it was 12.67 volts and was slowly climbing so I suspected my alternator was gone. I went to remove the plug and run it disconnected to see if there was any difference but closer inspection of the plug revealed that one lead was backing out and lost contact with the lead on the alternator. I slid the lead back in, plugged the connector, fired her up and she ran better than before and there was 14.6 or so volts across the battery but most importantly that damn battery light is off, for now... Lol. Thanks for the help guys!
     
  8. ttocs

    ttocs Legend

    Messages:
    25,426
    Likes Received:
    2,457
    Joined:
    Oct 9, 2009
    Location:
    Evansville Indiana
    ya know its funny how often gremlins end up being something really small and easy to fix and even find once your hands are on it. A close inspection on harnesses like this is always a good idea when disconnecting/connecting them.
     
  9. 07GtS197

    07GtS197 Well-Known Member

    Messages:
    1,391
    Likes Received:
    187
    Joined:
    Mar 16, 2015
    Location:
    Naples, Fl
    Im just glad I dont have to replace the alternator lol