Need someone smarter than me

Discussion in '94-95 5.0 - Specific' started by blazin80, Apr 21, 2014.

  1. blazin80

    blazin80 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Apr 21, 2014
    I have a 95 GT that I had a Trick flow HCI combo on it along with other bolt ons. The car sat for the past 6 years (house, kid, life ect happened). I had the motor out to have rebuilt and it never got done. After a long wait I started getting new parts and such late last year and putting the short block together, I had busted a lifter previously so I ordered a new trick flow stage 1 cam and put my shortblock all back together. When my Trick flow twisted wedge heads came back it turns out they had a small crack in them. So I changed the plan, went back all stock. Stock heads (which have cobra 1.7 rockers) and intake. Well after a very long weekend and a long monday I have everything together and everything seems to be in working order except for one small thing. I have zero compression. My buddy seems to think it maybe a mix of the 1.7 rockers and trickflow cam keeping the valves open. So I ask you guys. I did go back to the stock pushrod length with the stock heads. I have googled and googled but cannot find an answer.
     
  2. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    Did you ck compression on all cylinders or only 1?
    Could be stuck valves or lifters. Pull the vlv covers and rotate the engine by hand to make sure all the vlv's are opening and closing.
    Did you verify vlv lash. Did you measure for push rod length?
     
  3. blazin80

    blazin80 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Apr 21, 2014
    I did not check them to be totally honest, I had to leave to go pick up my son, but the car is in my buddies shop so he was working on it so he could get it out and get paying customers cars in there. When I left we were working on the timing, thinking it was seriously out of whack. He called me last night saying he checked the compression of cylinders on each side and both read zero, then checked his gauge and the gauge was good. Thats when he said something about the trick flow cam with the 1.7 rockers. Only thing is when the motor was on the stand the rockers had a little play in them unless that particular valve was open then it was tight? I have'nt checked them since turning the motor over in the car though. I did not measure for push rod length, just ran with the stock length.
     
  4. blazin80

    blazin80 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Apr 21, 2014
    THe more I read the more it looks like I should not be running that cam with stock valve springs at least. So whether its is my compression problem or not I think I will change the cam. Whats the closest to stock I can get?
     
  5. RichV

    RichV Well-Known Member

    Messages:
    4,227
    Likes Received:
    247
    Joined:
    May 6, 2012
    Location:
    CO
    I ran a E303 with stock pushrods, stock E7 heads, and stock 93 Cobra 1.7. No issues at all. Not sure how different your cam is.

    Can you remove a VC, remove a pair of rockers, and see if that cylinder gets the compression back? Probably have to do a leakdown tho. If it does, problem is not the valvetrain.

    I also read an issue where a guy had no compression, was trying to troubleshoot it, in the end it turned out he was not opening the throttle while cranking the engine so no air was getting into the cylinders. He opened the throttle while cranking and had compression
     
  6. blazin80

    blazin80 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Apr 21, 2014
    Yeah thats the plan for the next step, remove the valve covers and check the rockers. Will keep the throttle part in mind though, but I did tap the gas pedal a couple times yesterday while trying to crank.

    I will probably just go back with a stock cam, at this point I would just like to have the car to drive with no issues. It was a fun car back when I didn't have kids or mortgage, didn't mind throwing money at it :) . Different story now though. Gonna try to keep the motor stock but maybe update exhaust and maybe some body parts.
     
  7. blazin80

    blazin80 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Apr 21, 2014
    That's if I get it running.
     
  8. RichV

    RichV Well-Known Member

    Messages:
    4,227
    Likes Received:
    247
    Joined:
    May 6, 2012
    Location:
    CO
    It's just money. You'll make more. :)
     
  9. whiplash473

    whiplash473 Moderator Staff SN95 Supporter

    Messages:
    12,251
    Likes Received:
    1,205
    Joined:
    May 12, 2012
    Location:
    Northern IL
    I ran a similar setup before, no issues.

    The TFS Stage 1 cam is similar to the E303 so you should be fine there.
     
  10. blazin80

    blazin80 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Apr 21, 2014
    True, just getting harder to hold onto it long enough to do what I want with it.
     
  11. whiplash473

    whiplash473 Moderator Staff SN95 Supporter

    Messages:
    12,251
    Likes Received:
    1,205
    Joined:
    May 12, 2012
    Location:
    Northern IL
    You mean like getting fed up with it? Trust me, the majority of the members on here have been there at least once.
     
  12. blazin80

    blazin80 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Apr 21, 2014
    Was trying to reply to a Post up that ^ way. Turns out I have to hit "reply with quote" which I thought I was doing when I hit reply. I'm an idiot.

    Was getting a lil frustrated with it but had our first tball game of the season today so that brought me back around. I'll get it going sooner or later.
     
  13. whiplash473

    whiplash473 Moderator Staff SN95 Supporter

    Messages:
    12,251
    Likes Received:
    1,205
    Joined:
    May 12, 2012
    Location:
    Northern IL
    No worries, help is what we're here for.
     
  14. blazin80

    blazin80 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Apr 21, 2014
    Just to cover everything, did you guys change your pushrod length when you ran a cam with stock heads and 1.7 rockers?
     
  15. CobraClone94

    CobraClone94 Active Member

    Messages:
    982
    Likes Received:
    33
    Joined:
    Apr 19, 2008
    Location:
    When i figure it out, You'll be the first to know.
    I also ran e303 with E7 heads with stock rod length in my 85 GT and had no issues..
     
  16. RichV

    RichV Well-Known Member

    Messages:
    4,227
    Likes Received:
    247
    Joined:
    May 6, 2012
    Location:
    CO
    No. OEM Ford is what I had. Still have all the same components, but with GT40P heads.
     
  17. blazin80

    blazin80 New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Apr 21, 2014
    It finally ran :) . It ran rough, will definitely need some tinkering but it did crank up and run.