nitrous back fired...etc....what to do now...car wont idle

Discussion in 'Forced Induction & Tuning' started by cody0170, Jul 30, 2007.

  1. cody0170

    cody0170 Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    so last night i went to the track and about half way down while i was spraying it backfired. went to the pits and the cai tube blew off the throttle body. the sensor blew out of the tube thats behind the mass air flow sensor and now you start it up and it idles like it has a bad ass cam. so it wont idle. when you try and give it gas and refuses to respond. if you mash the throttle to wot then you can manage to somewhat drive. so thats how i drove it home last night on the expressway for like 15 miles.......wtf happened...
     
  2. ripper

    ripper Well-Known Member

    Messages:
    3,323
    Likes Received:
    0
    Joined:
    Jan 2, 2007
    Check your intake for a crack. It sounds like a vacuum leak. Or maybe you trashed the MAF itself.
     
  3. scarface

    scarface Guest

    look for a blown gasket
     
  4. quickstang_1994

    quickstang_1994 Well-Known Member

    Messages:
    2,208
    Likes Received:
    12
    Joined:
    Apr 30, 2006
    Location:
    Cross Anchor, SC
    Plastic intakes leak after a back fire.
     
  5. Paul

    Paul Legend

    Messages:
    9,894
    Likes Received:
    242
    Joined:
    Apr 30, 2007
    Check MAF first, then vaccuum leaks. Do you have a CEL?
     
  6. cody0170

    cody0170 Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    whats a CEL
     
  7. scarface

    scarface Guest

    Check Engine Light
     
  8. cody0170

    cody0170 Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    OK so i just went to O'reilly's and bought new plugs, MAF spray cleaner and a new fuel filter. I'm going to try them in that order and see if i can get anything out of it. really fucking wild how this just happened and now it runs like dog shit. I hope I didn't blow a intake gasket. if so I'll prolly start looking to do a pi intake swap. O YA LATEST NEWS......BLEW DONUT GASKET ON PASSENGERS SIDE EXHAUST MANIFOLD
     
  9. cody0170

    cody0170 Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    No I don't have a Check engine light.
     
  10. rick focks

    rick focks Legend

    Messages:
    13,602
    Likes Received:
    6
    Joined:
    Jan 8, 2007
    if you can drive to dfw and pull it, you can get a nice '02 pi motor dirt cheap 8)
     
  11. cody0170

    cody0170 Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    so i just replaced my spark plugs and used a spray cleaner specially for MAF and the sensor behind the MAF..... well it still will not idle..... sounds like its not getting the right amount of fuel. someone even told me to remove the positive cable from the battery for 15 minutes then put it back on and that should reset the computer. well it was off all last night and it still isn't right
     
  12. 19mustang95

    19mustang95 Legend

    Messages:
    6,137
    Likes Received:
    2
    Joined:
    Jun 25, 2006
    is your IAT sensor (the one that blew off, behind the MAF) did you make sure that it wasn't broken. i know when mine wasn't in, my car idles like crap.
     
  13. cody0170

    cody0170 Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    well it blew off and i dont know if it is damaged or not but since it backfired it had black carbon on the sensor thing and so i used that spray cleaner on it to remove the gunk and re-inserted it in the CAI. Would that be neccessary to be replaced.
     
  14. quickstang_1994

    quickstang_1994 Well-Known Member

    Messages:
    2,208
    Likes Received:
    12
    Joined:
    Apr 30, 2006
    Location:
    Cross Anchor, SC
    still sounds like a vaccum leak in the intake. nitrious is well know for doing this with a plastic intake
     
  15. cody0170

    cody0170 Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    so i had a friend of a friend come by my house yesterday and look at my car. he is a self employed mechanic and he ended up telling me that i had a major vacuum leak on the bottom of my intake manifold. we didn't take it off so we didn't know if its just the gaskets or if i have a cracked intake. hope its just the gasket. if its the intake itself what should i replace it with. stock npi, pi intake, or all aluminum...... and what do these cost.
     
  16. cody0170

    cody0170 Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    So i just removed the intake. Wow never saw a intake with a big hole in the bottom of it!.. :mad: So when i removed it from the car i saw that and within 5 minutes i leaned it up against the wall and turned the garage lights and just shut the door. It kinda hit me weird. Like the words were shit fuck and then i was speechless. what to do now?????
     
  17. scarface

    scarface Guest

    PI intake swap is a good route, but you may blow that one out too.
     
  18. quickstang_1994

    quickstang_1994 Well-Known Member

    Messages:
    2,208
    Likes Received:
    12
    Joined:
    Apr 30, 2006
    Location:
    Cross Anchor, SC
    With nitrious a aluminum intake is the best but I would put a plastic one back on there($$$) and find out why the kit backfired. Are you trying to powershift? If so dont its not worth the extra .05 or maybe a tenth.
     
  19. cody0170

    cody0170 Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    i think it backfired because i was shifting to close to 6K. and i wasnt running colder plugs but i was running 104 fuel. how do i install an pi intake on npi heads. what all do i need to do this.. if i dont shift so high in the rpms and run 1-2 colder plugs will this keep happening or will it eliminate it.
     
  20. cody0170

    cody0170 Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    OK problem found and fixed. Removed lower intake and on the back there is a 3x2 inch hole from when it backfired from the nitrous. everything is fine now after i ordered and installed some new colder plugs and intake.