No A/C!!

StangerBanger

New Member
Joined
Sep 13, 2013
Messages
72
Reaction score
0
i have owned my SN for about 5 years now and the whole time i have had it, the air conditioning has never really worked, or blown cold anyway.. i tried the whole recharge in a can gimmick, and it didn't work of course, so i just learned to deal with the heat, but now i am over it and it is time to fix it!! any suggestions as to where i should start?? i am aware that the whole system is under high pressure so i shouldn't go disconnecting anything before the system is purged.


also, it does not blow air from the center dash vents, hot or cold..
any and all suggestions are appreciated, thanks
 

fran5o

New Member
Joined
Apr 23, 2015
Messages
29
Reaction score
0
Could be a whole load of issues, electrically, mechanically, or both.
Do you have 12v at the compressor with the ac on?
 

07GtS197

Well-Known Member
Joined
Mar 16, 2015
Messages
1,844
Reaction score
424
Location
Naples, Fl
If you wanna solve this yourself Id suggest investing in a set of manifold gauges as well. If its not electrical then its your best bet at solving what the problem is. So what exactly is it doing?
 

CC'S95GT

Post Whore
Joined
Apr 19, 2008
Messages
10,738
Reaction score
172
Location
Hampton ,Ga.
Your interior vents are vacuum operated and when you loose vacuum the vents will automatically default to defrost.
Usually the brake is a very small line that runs across the firewall from the driverside vacuum tree to the pasenger side where it enters the cabin.
 

ttocs

Post Whore
Joined
Oct 9, 2009
Messages
28,317
Reaction score
3,866
Location
Evansville Indiana
just add a 2nd nozzle for the meth kit, in your air vents and you will not worry about being cold anymore.
 
OP
OP
S

StangerBanger

New Member
Joined
Sep 13, 2013
Messages
72
Reaction score
0
not sure if i have 12v at the compressor, im going to play around with it this weekend, that is something ill definitely check.

and i have heard of the vacuum lines causing issues, i have checked them just to make sure they were in tact and hooked up, however i did not look closely for splits down the middle, that's a great suggestion, thank you

07GtS197 air does not blow from the center dash vents, however is does blow from the defrost and from the two small side vents on the dash. it also does not blow cold air. so basically the a/c just all around has issuers and does not work
 

07GtS197

Well-Known Member
Joined
Mar 16, 2015
Messages
1,844
Reaction score
424
Location
Naples, Fl
Damn, yea you might as well check all the electrical connections first then recheck the vac lines with a fine tooth comb. I recently had to replace my evaporator core in my driveway so I feel your pain man.
 

87hurricane

Member
Joined
Jan 17, 2015
Messages
110
Reaction score
1
Your vent issue is probably vac related. As for the A/C it could be electrical or a low charge or leak in the system. Does the compressor run at all?
 
OP
OP
S

StangerBanger

New Member
Joined
Sep 13, 2013
Messages
72
Reaction score
0
the broken vac line was the issue! i made a few small repairs and now have air flowing from all vents. i also went to autozone and reluctantly bought a can of refidgerant and to my surprise it helped alot! for the first time since i have owned this car, ai can now drive around with the windows up, comfortably! soo stoked! its going to be 95 degrees here in reno today, so the timing could not be better!
 

Latest posts

Forum statistics

Threads
75,161
Messages
1,456,737
Members
13,699
Latest member
Adultingsucks

Members online

Top