Oil Pressure Issue

Discussion in '94-95 5.0 - Specific' started by Bub, Jun 28, 2014.

  1. Bub

    Bub Active Member

    Messages:
    535
    Likes Received:
    15
    Joined:
    Mar 16, 2012
    Location:
    Pistakee Highlands
    Okay just got done with a H/C/I swap stock rotating assembly. I have about 150 miles on the car and a hour or two of idling. I've noticed that oil pressure is good on start up (idle issues of course) however as I drive around and warm the car up. When I get to low speeds or red lights my oil pressure on the stock gauge drops to low or nothing. If I feather the gas it comes back up and when I'm driving its normal. I'm not sure where to begin looking. Thanks!
     
  2. DeepList

    DeepList Administrator Admin SN95 Supporter

    Messages:
    9,693
    Likes Received:
    321
    Joined:
    Jan 2, 2013
    Location:
    Auburn, IN
    The stock oil pressure gauge is about a useless piece of junk. Essentially, it's just an over-glorified idiot lamp and it will either show that you have pressure, or you don't. There may not be a real issue at all.
     
  3. toyman

    toyman Active Member

    Messages:
    874
    Likes Received:
    9
    Joined:
    Aug 25, 2008
    It is important to the extent that it's a warning. The warning pressure is 6 psi. In that sense it should never come on with the engine running. I would remove the switch a thread in a gauge to see the actual pressure. If it's good (40+ psi) replace the switch.
     
  4. Bub

    Bub Active Member

    Messages:
    535
    Likes Received:
    15
    Joined:
    Mar 16, 2012
    Location:
    Pistakee Highlands
    Switch replaced everything seems to be better now thanks!