Oil pressure

Alocalguy1337

New Member
Joined
May 26, 2024
Messages
8
Reaction score
6
The other day my oil pressure guage was moving side to side very fast now its showing low im also having an issue with my coolant guage not moving
 

96blak54

Moderator
Staff
Joined
Feb 21, 2011
Messages
10,170
Reaction score
3,062
Location
Lawrenceburg Kentucky
Sounds like a Ford...lol

Seriously tho, the oil pressure sensor is a simple switch that requires like 5psi of pressure to actuate. Its probably faulty and very common to fail. Its location is around the oil filter. Cheap part, easy to swap. Be sure the plug is on good and the wire isnt damaged too.

Im also throwing out there the possibility of some sort of bad connection or wiring gremlin ....IF.....both gauges are acting funny at the sametime.

We here to help. Just keep us informed
 

badass98svt

Well-Known Member
Joined
Jan 11, 2006
Messages
4,210
Reaction score
1,934
The oil pressure sensor is a simple switch that requires like 5psi of pressure to actuate. Its probably faulty and very common to fail.

This is all true. However, the last time my Oil pressure gauge did as described, I spun a bearing. (back and forth quickly before showing low oil pressure)
 

RAU03MACH

Legend
Joined
Apr 23, 2019
Messages
7,045
Reaction score
6,887
Location
NEW MEXICO
make sure that wire connection is no good and tight with no corrosion on post
that plug in is a pain in the ass coming lose and the signal is all over the place
 

cobrajeff96

Well-Known Member
Joined
Feb 1, 2022
Messages
1,755
Reaction score
1,651
Location
Germany
Some of these gauges actually share common sensor grounds and/or common voltage supply. Not saying it is or isn't in your case, but it might be it. What year/model?
 

Forum statistics

Threads
77,653
Messages
1,506,536
Members
15,083
Latest member
ConnorBlue4Mustang

Members online

Top