Ok really need help.

dntgtbit

New Member
Joined
Apr 19, 2014
Messages
21
Reaction score
0
Ok my car was running great for 2 weeks. Drove it daily with no issues at all. One day I was driving home and it died. Tried to restart it, all it would do is crank. Wouldnt even begin to start. So I pulled it home. Went out the next day to mess with it. When I turned the key no power at all. I tried a new battery but when I went to hook it up it threw sparks really bad. Sounds like a grounding issue to me but I don't know where to start. Please help.

Sent from my SAMSUNG-SGH-I317 using Tapatalk
 

dntgtbit

New Member
Joined
Apr 19, 2014
Messages
21
Reaction score
0
Might mention its a 95 cobra supercharged, has msd ignition and battery in the trunk.

Sent from my SAMSUNG-SGH-I317 using Tapatalk
 

ElrodKTPQ_89

Legend
Joined
Aug 6, 2013
Messages
5,078
Reaction score
151
Location
Crossett, AR
Same thing happened with my car in November. No luck yet lol. Good luck man I'll keep a check to see if you get it figured out!
 

1bad95

Well-Known Member
Joined
May 6, 2009
Messages
1,488
Reaction score
14
Sounds like could be a bad distributor

Sent from my XT1080 using Tapatalk
 

blackdemon007

Active Member
Joined
Aug 31, 2013
Messages
286
Reaction score
0
Location
Ohio
Same thing just happened to my buddy. Starter solenoid went out and killed the battery. Replaced the starter and charged the battery. All good now. Hope this helps.
 

MecGen

New Member
Joined
May 24, 2014
Messages
16
Reaction score
0
I would check your positive cable from the battery to the starter, might be chaffed and shorted out. You will have to check your fuses, after the repair. Alternator short could cause this as well, with your battery disconnected remove the large 12 volt wire from it, and retry.

Good luck
 

Latest posts

Forum statistics

Threads
75,133
Messages
1,456,288
Members
13,688
Latest member
Pallgor

Members online

Top