Over drive light flashing

Discussion in 'The Garage' started by grimreaper_72, Jan 6, 2016.

  1. grimreaper_72

    grimreaper_72 Member

    Messages:
    235
    Likes Received:
    0
    Joined:
    Feb 19, 2015
    Location:
    BENEDICT, NEBRASKA
    My over drive light was flashing this morning it quit after a few minutes, shifted fine, it's a 96 gt

    Sent from my SM-G920V using Tapatalk
     
  2. 1994stangfan

    1994stangfan Active Member

    Messages:
    428
    Likes Received:
    14
    Joined:
    Dec 29, 2015
    Location:
    Ontario canada
    Check for codes. It could be nothing. But it could also be solenoid pack, or wiring issue.
     
  3. ElrodKTPQ_89

    ElrodKTPQ_89 Legend

    Messages:
    5,068
    Likes Received:
    127
    Joined:
    Aug 6, 2013
    Location:
    Crossett, AR
    My buddy had that problem with his 98 GT...turned out to be a bare spot in two of the wires coming in contact with each other.
     
  4. 9838stang

    9838stang Well-Known Member

    Messages:
    2,539
    Likes Received:
    141
    Joined:
    Sep 13, 2010
    Location:
    Minneapolis,MN
    I had that happen in my 98 v6. I took it into the shop and it turns out that the 1st to 2nd shift solenoid was going out or at least it showed a fault. When they got inside of it the solenoid was actually punching through where the spring and everything is set inside of the transmission valve body. The fix was a new solenoid stiffer spring and a sleeve where everything sits in on the valve body since then I haven't had any issues. It may also be from low transmission fluid or dirty transmission fluid. When was the last time the transmission was flushed
     
  5. grimreaper_72

    grimreaper_72 Member

    Messages:
    235
    Likes Received:
    0
    Joined:
    Feb 19, 2015
    Location:
    BENEDICT, NEBRASKA
    changed the fluid and filter when I bought the car about a year ago, I still need to scan to see if I have any codes or not, I have a 7015 SCT, we'll see if anything comes up, this morning no light and did not have the light when I drove home last night