PASSENGER SIDE 02 LOCATION- MAC LONGTUBE HEADERS

the5.ohh

Legend
Joined
Oct 15, 2012
Messages
9,555
Reaction score
108
Location
Shaolin, NY
I'm ready to replace my 02 Sensors. I have MAC Longtube headers. Found the drivers side, but the passenger side is no where in sight? Looked at the header inside and out, nothing, midpipe, nothing, in the engine bay, nothing.. Am I missing something here?
 

the5.ohh

Legend
Joined
Oct 15, 2012
Messages
9,555
Reaction score
108
Location
Shaolin, NY
Seems like your missing the passenger O2 sensor. .

Enviado usando mi SHP-L710 usando TapaTalk

Guy who did the longtubes just told me the O2 Sensor is there. He just scanned the car a few days ago and told me the O2 Sensors were bad.
 

rz5.0

Legend
Joined
Mar 26, 2010
Messages
5,853
Reaction score
130
Location
Great state of TEXAS
Should be right across from the driver side. Maybe it broke off..

Enviado usando mi SHP-L710 usando TapaTalk
 

rz5.0

Legend
Joined
Mar 26, 2010
Messages
5,853
Reaction score
130
Location
Great state of TEXAS
You should be able to see the driver side turn to look at the pass side and be right there

Enviado usando mi SHP-L710 usando TapaTalk
 

the5.ohh

Legend
Joined
Oct 15, 2012
Messages
9,555
Reaction score
108
Location
Shaolin, NY
K well its pooring out, so I can't get it up on ramps. Tomorrow ill get it on ramps and find it, can't see to much from the floor lol
 

Forum statistics

Threads
74,475
Messages
1,447,324
Members
13,357
Latest member
Mustang 351

Members online

Top