Please help!! My car is hesitating.

Discussion in '94-95 5.0 - Specific' started by RJMC, Jan 28, 2015.

  1. RJMC

    RJMC New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Sep 28, 2014
    Location:
    Tennessee
    https://www.facebook.com/video.php?v=1563369103905472

    the link above includes a video of my 94 GT running quite odd.
    It was doing good since ive had it until now. When im in neutral and give it a steady rev It sputters/shudders/misfires/bucks/hesitates whatever you want to call it, even does it while im driving.
    I have already changed the IACV, Fuel filter, Plugs and wires, and dizzy cap. I am out of ideas.
    Someone told me it could be that the alternator is going out but im not sure. I really dont want to give up on old judy (my car) :(
    If someone ever had this problem before and found the fix please let me know.
    any ideas/advice are helpful. Thanks.
     
  2. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    First, have you pulled codes? You can have one set without the CEL being on. The OBD2 port on your car doesn't work cuz yours is OBD!. get a Haynes manual.
    2nd, what kind of plugs? 5.0's don't like platinum's.
    3rd. Do you have a multimeter to ck voltage output of alt? If not then take to the parts house to be tested.
    4th, clean the MAF. Use MAF cleaner.
    5th, Did YOU change the plugs, wires, etc or have a shop? If you did it then double ck your firing order