Pretty bad pinging only under acceleration.

Discussion in '96-04 - 2V Specific' started by Burninrock24, May 19, 2014.

  1. Burninrock24

    Burninrock24 Active Member

    Messages:
    602
    Likes Received:
    46
    Joined:
    Mar 19, 2013
    Location:
    Minneapolis, MN
    Pulled it out of storage put new 93 octane gas in and it's pinging pretty bad. Sounds less rhythmic like a knock and more like leaves in your blower vent. This video sounds exactly like it towards the end around 20 seconds:

    http://www.youtube.com/watch?v=6xTWHJADFe8

    It runs perfectly smooth outside of WOT. Idle is fine, and it will rev to the limiter while not under load no problem. Where should I start looking to fix?
     
  2. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    prob just bad gas.
    run that tank out and let us know how the next tank doas.
     
  3. Burninrock24

    Burninrock24 Active Member

    Messages:
    602
    Likes Received:
    46
    Joined:
    Mar 19, 2013
    Location:
    Minneapolis, MN
    Okay so I ran the 93 out and two CEL codes came out P0430 and P0420. Put new 93 in with octane booster and the ping is completely gone. So that's good, but I want to get these figured out.

    I've got a BBK catted X so I don't think the cats are failing, so I'm thinking O2 sensors. Guy at the shop said that a MAF might throw both of those codes. Any ideas?

    edit: Looked around the forums and it seems that its because high flow cats don't work well enough to satisfy the sensors threshold values so it throws these codes. Easy fix with some eliminators.
     
  4. CC'S95GT

    CC'S95GT Legend

    Messages:
    10,738
    Likes Received:
    172
    Joined:
    Apr 19, 2008
    Location:
    Hampton ,Ga.
    why the need for octane booster too?
    Have you changed the plugs and wires too?
     
  5. nightfire

    nightfire Member

    Messages:
    162
    Likes Received:
    0
    Joined:
    Nov 21, 2012
    Location:
    TX
    You're detonating my friend. You're probably hearing it now as the temps heat up outside. Lower the timing or run higher octane.
     
  6. Burninrock24

    Burninrock24 Active Member

    Messages:
    602
    Likes Received:
    46
    Joined:
    Mar 19, 2013
    Location:
    Minneapolis, MN
    Meh just tossed it in there to be absolutely sure that it was detonation, I don't plan on doing it with every fill up, just seemed like a decent way to narrow it down for sure.

    Wires are probably 15,000 miles, spark plugs are a hair older.
     
  7. 96blak54

    96blak54 Legend

    Messages:
    7,457
    Likes Received:
    772
    Joined:
    Feb 21, 2011
    Location:
    Ky
    Egr sensor