Prob with my shifter...

eliyarbrough

Legend
Joined
Jan 30, 2007
Messages
7,848
Reaction score
0
Location
Nocona, TX
I have a problem and have no clue how to fix it! I have a 95 GT Automatic. When I go to put it in gear I have that button to press. It is kind of stuck! About every 12th time it works fine. Those other 11 times suck. If I press hard, it goes in. I was wondering if this has happened to someone else’s car. How do I correct it? I am thinking I will need to take the shifter off itself. Is it like my E-brake was kind of? With a tiny screw holding it on, I mean. Thanks in advance!!
 

eliyarbrough

Legend
Joined
Jan 30, 2007
Messages
7,848
Reaction score
0
Location
Nocona, TX
On that screw, what is it? I have every size Allen wrench it took to install my billet pieces in my ashtray. I tried all of them and nothing worked. I went and got my Allen wrenches in my toolbox and nothing there too. What unscrews it? See ya!!
I am trying to get my shifter off to see if I can oil up the switch itself. I had to sand on the sides of the button on my E-brake. Kind of using the same tactics. All I knew to do! Thanks!!
 

eliyarbrough

Legend
Joined
Jan 30, 2007
Messages
7,848
Reaction score
0
Location
Nocona, TX
Oh, another thought! Like today 2/5, it started out shifting fine. Later in the day it started sticking again. And, how come it only does it in Park? When I go from D to R, and back it does not stick! I just thought of that. See ya!!
 

eliyarbrough

Legend
Joined
Jan 30, 2007
Messages
7,848
Reaction score
0
Location
Nocona, TX
Pennywise2 said:
I would do a T-5 transmission swap.
Was this to me? I just have problems with my shifter and your advice is a new tranny. Can you get a T-5 in an automatic? I am not so good with a clutch now!!! I want one, but it is not smart to have it. See ya!!
 

Latest posts

Forum statistics

Threads
74,891
Messages
1,452,682
Members
13,573
Latest member
ISmeelBaon

Members online

Top