radiator help!! Urgent

98vortech

Member
Joined
Jan 1, 2007
Messages
115
Reaction score
0
Hey guys i just got my new radiator in and everything hooked up. filled it with antifreeze started it up and it got really hott. FAST. SO i backed it out of the garage and i have to give it a lot more gas than normal for me to be able to go anywhere because it seems like it will die. Then the check engine light came on and my temp gauge was at 225 degrees so i shut it off and quit foir the night...Does anyone know wat i could have done to make it do this??
thank you guys so much for any replies!!
 

Red96GT

Legend
Joined
Sep 23, 2006
Messages
5,374
Reaction score
1
How fast did it overheat? Did you check the oil?

Start with the obvious first.
 
OP
OP
9

98vortech

Member
Joined
Jan 1, 2007
Messages
115
Reaction score
0
well it overheated after i drove it around the block so about 5 mins. and the oil is pefrect i just changed it... :noes:
 

cmher18

Active Member
Joined
Jan 4, 2007
Messages
359
Reaction score
0
If just put it in Leave the cap off and let it run

Sounds like u have air in the system. Its normal to get that after changing coolent and stuff.
 

Red96GT

Legend
Joined
Sep 23, 2006
Messages
5,374
Reaction score
1
98vortech said:
are you sure??? cuz i am flippin out!!!

If you've got oil and coolant it almost has to be air in the system. :dunno:

Was the fan running?
 
OP
OP
9

98vortech

Member
Joined
Jan 1, 2007
Messages
115
Reaction score
0
i have no clue. the car is running like balls. But i un-plugged tha battery then plugged it back up and no light. but still runs weird...like it will choke if i dont ride the clutch ous just to pull it in the garage.. :-\
 

19mustang95

Legend
Joined
Jun 25, 2006
Messages
6,137
Reaction score
5
of course you won't get another check engine light if you unplug the battery since it resets the computer...do you have an Xcal2 or a handheld tuner?
 
OP
OP
9

98vortech

Member
Joined
Jan 1, 2007
Messages
115
Reaction score
0
k guys i am not getting any power to the fan but i am getting a groung. :-\ so anyone know wat the problem could be???
 
OP
OP
9

98vortech

Member
Joined
Jan 1, 2007
Messages
115
Reaction score
0
yea the fuse under the hood is good and thats the only one i know of if there isnt one hiddein somewhere..
 

Latest posts

Forum statistics

Threads
77,715
Messages
1,508,551
Members
15,137
Latest member
Rayne

Members online

Top