Ran at englishtown tonight.. heres the results

ReVz

New Member
Joined
Apr 6, 2006
Messages
35
Reaction score
0
I ended up running both my cars tonight

2004 ran 14.4 @ 96

1994 ran 15.1 @ 91

Another problem im having is tho in my 5.0, the throttle keeps stickin.. what could be causing this.. and would of had a major inpact on my time? I feel like i could of done a whole lot better wit my 5.0... did I do good or bad? A little help please. I gotta fix that damn Sticking problem
 

94gtstang50

Well-Known Member
Joined
Feb 21, 2006
Messages
2,044
Reaction score
0
I'd say thats a decent time, probably could have been in the 14's if the weren't any problems but still a good time.
 

ReVz

New Member
Joined
Apr 6, 2006
Messages
35
Reaction score
0
How do I fix this stupid thing... its so annoying
 

ReVz

New Member
Joined
Apr 6, 2006
Messages
35
Reaction score
0
Its just so much harder to push the pedal down. And my boy said its sticking to.. its just getting worse an worse.. is it something wit the cable?
 

jimgt95

New Member
Joined
Apr 10, 2006
Messages
82
Reaction score
0
I would say, disconnect your throttle cable and spring at the throttle body. Pull off your CAI so you can see into the TB. Grab the throttle linkage on the body and move the blade from closed to full open several times checking to make sure that there is no interfernce or sticking. If it looks really dirty, buy some carb cleaner and clean it up. If everything moves/looks ok on the TB end, then I would start to inspect the springs and cable for wear or dirt (or a pinch point in the engine bay) that could impede their movement. If they look ok, then I would take a look at the pedal assembly itself because there may be something caught in the pivot points or they may need a quick shot of lubrication. Let us know what you find.
 

Addermk2

Well-Known Member
Joined
Mar 7, 2006
Messages
2,524
Reaction score
47
Ive got a stock cobra TB that ill send out to you.... gimmie $10 and pay the shipping

sound good??? ill get you some pics if your interested
 

ReVz

New Member
Joined
Apr 6, 2006
Messages
35
Reaction score
0
I got a 70mm TB on. I just put in on a week ago. The Throttle is just sticking on me. Its something wit the stupid cable
 

Latest posts

Forum statistics

Threads
74,991
Messages
1,454,223
Members
13,624
Latest member
Thilton247

Members online

Top